SOLVED Can't locate whmlib.pm

Marlon Lamprea

Registered
Nov 16, 2014
1
0
1
Quezon City, Philippines, Philippines
cPanel Access Level
Root Administrator
Error cwaf After updating to WHM 62.0 build 1 Can't locate whmlib.pm

Code:
Can't locate whmlib.pm in @INC (you may need to install the whmlib module) (@INC contains: /usr/local/cpanel /usr/local/cpanel/whostmgr/docroot/cgi /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/5.24.1/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/5.24.1 /opt/cpanel/perl5/524/site_lib/x86_64-linux-64int /opt/cpanel/perl5/524/site_lib) at /usr/local/cpanel/whostmgr/docroot/cgi/addon_cwaf.cgi line 9.
BEGIN failed--compilation aborted at /usr/local/cpanel/whostmgr/docroot/cgi/addon_cwaf.cgi line 9.
[2017-01-07 17:04:03 +0800] info [whostmgrd] Internal Server Error: "GET /cpsess7665472542/cgi/addon_cwaf.cgi HTTP/1.1" 500 No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/addon_cwaf.cgi): The subprocess reported error number 2 when it ended.
 
Last edited by a moderator:

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
The deprecated whmlib.pm module was removed from distribution in cPanel & WHM version 62. Please contact the addon vendor/maker for an updated version that does not depend upon the module.