SOLVED Cant log in to my server from other computers

yexxio

Member
Jun 5, 2021
8
1
1
Spencer WV
cPanel Access Level
Root Administrator
I have set up my own server instead of renting one, it is set on a static IP, like it should be I can log into the server, but I can only log into Cpanel directly from the server.

Cent OS 7

Also when i type my ip (66.76.210.120:2083) the address changes to: https://75-109-60-201.porycmtk01.com.dyn.suddenlink.net:2083/

The websites are live and working and I can log in no problem from the server itself but I do not want to log into the server itself.

What am I doing wrong here? It has been nothing but hassles for two weeks (sorry to complain) like I said I am not a server expert and I really would like to just get back to working on my freaking websites.

Any help appreciated, thank you
 

cPJustinD

Administrator
Staff member
Jan 12, 2021
183
36
103
Houston
cPanel Access Level
Root Administrator
Hello yexxio!

Regarding the redirect that you mentioned, it appears that 66.76.210.120:2083 is redirecting to the server's provided hostname as that is the secured server hostname and port 2083 is meant for secured connections. This is expected behavior. You can also change your hostname if you prefer. You can find more information on this below:

How to change the server's hostname from WHM
How to change the hostname over SSH

Regarding the cPanel login failures from locations outside of the server, what specific errors are you encountering when attempting to log into cPanel from outside of the server? Are you receiving a login failure as a cPanel user or another user? Also, as you mentioned you can log in directly from the server, would this be via the cPanel icon next to the affected accounts under WHM » List Accounts? This information should provide us with a better understanding of what is occurring.

We look forward to hearing back from you!
 

yexxio

Member
Jun 5, 2021
8
1
1
Spencer WV
cPanel Access Level
Root Administrator
Thanks for the response. I was a little concerned because while renting dedicated servers I never noticed it redirect like that. I am glad to hear that is normal.

As for the Cpanel login. I fixed it.
Turns out I needed to do an update, which I was putting off. I did the update and rebooted, then the network manager wasn't working so got that squared away and the server is working perfectly fine and I can log into CPanel from any device connected to the internet now.