The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Can't login as root after update

Discussion in 'General Discussion' started by Enrique Conci, Jan 10, 2017.

  1. Enrique Conci

    Enrique Conci Registered

    Joined:
    Jan 10, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Hi there!

    I'm having a curious issue when trying to login to WHM as root.

    This is what happens:
    1 - I go to my WHM root URL and use as root. The authentication is OK.
    2 - The next screen ask me for the security questions (I don't have a fixed IP)
    3 - Instead of showing the actual WHM, it loops back to the login screen again.

    I've access via ssh to the server, as root.

    This is what I've tried (and didn't work)
    A - Restart the CPanel process.
    B - Shutdown the cphulkd process.
    C - Try to access directly by using the IP address.

    By tailing the secpol_log file, I see a new entry like this, created every time:
    [2017-01-10 16:40:52 +0000] info [securitypolicy] Security Policy Verified: ['SourceIPCheck'], User: ['root'], Appname: ['whostmgrd'], IP: ['172.1.2.3']

    I'm sorry is this is not the right place to post this, but at this point I'm a bit desperate

    Any help or suggestion is more than welcome!

    Thanks
    Enrique
     
    #1 Enrique Conci, Jan 10, 2017
    Last edited by a moderator: Jan 10, 2017
  2. Enrique Conci

    Enrique Conci Registered

    Joined:
    Jan 10, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    As additional and perhaps useful information, this is what I see in the session_log file when I try to login:

    [2017-01-10 17:19:56 +0000] info [cpsrvd] 172.68.25.156 NEW root:2_Arr_ABCD
    address=172.68.1.2,app=whostmgrd,creator=root,method=handle_form_login,path=form,possessed=0

    [2017-01-10 17:20:00 +0000] info [cpsrvd] 172.68.1.2PURGE root:2_Arr_DFGH badpass [cookie ip check: IP address has changed]

    >> At this point it brings up the security questions which I answer, but then it just routes me back to login.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,999
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You can disable the security questions by modifying SecurityPolicy::SourceIPCheck=1 to SecurityPolicy::SourceIPCheck=0 in /var/cpanel/cpanel.config and then restarting cPanel:

    Code:
    /scripts/restartsrv_cpsrvd
    Let us know if this allows you to access WHM. If so, try setting the Security Questions again and see if the issue persists.

    Thank you.
     
  4. Enrique Conci

    Enrique Conci Registered

    Joined:
    Jan 10, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Michael,
    Thanks for your quick response.

    Unfortunately, that changed something, but still not working as expected.

    Looks like I can login just fine, but I see no icons or images in the WHM panel.

    i.imgur.com/u4MkZiB.png

    If I click in any of these links, I go back to the login screen :(
     
    #4 Enrique Conci, Jan 10, 2017
    Last edited by a moderator: Jan 10, 2017
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,999
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Are you using a proxy service such as CloudFlare?

    Thank you.
     
  6. Enrique Conci

    Enrique Conci Registered

    Joined:
    Jan 10, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Yes, I just found that.
    I confirm that CloudFlare is causing this issue as I'm able to login just fine if I add the server IP to my host file.

    I'm wondering if this is related to an ongoing issue with CloudFlare. Do you recommend to stop using it?

    Thank you very much for your help!!!
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,999
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Enrique Conci likes this.
Loading...

Share This Page