The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't login to cpanel using http://mydomain.com/cpanel

Discussion in 'General Discussion' started by Dayu, May 27, 2007.

  1. Dayu

    Dayu Member

    Joined:
    Aug 13, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I tried searching the forum and the web but I can hardly find the solution to this.

    Problem:
    Our users can not login to their cpanel account through http://domainname.com/cpanel which they have usually done before. We don't know what went wrong. We tried to upgrade cpanel but it doesn't help. It gives this error:

    Thanks in advance for any help.
     
  2. bashcpanel

    bashcpanel Well-Known Member

    Joined:
    Apr 15, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    Check if your users can browse http:domainname.com:2082 .. if they can ... it means that one entry is missing in httpd.conf file.

    You can solve this problem by editing httpd.conf file

    1) Login as Root in server
    2) open httpd.conf file
    3) Search for "ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi" line ... if it is missing add it and restart apache.

    It should solve your problem.

    Let us know if every thing goes fine there . :)
     
  3. Dayu

    Dayu Member

    Joined:
    Aug 13, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the quick reply. :D

    I added the code and restart the server. But now it gives a url not known to me and resolves to not found.

    Where can I change that url?
     
  4. bashcpanel

    bashcpanel Well-Known Member

    Joined:
    Apr 15, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    For this problem you need to open "/var/cpanel/cpanel.config" file in server.

    1) vi /var/cpanel/cpanel.config
    2) Search for option alwaysredirecttossl and change it to 0
    3) Restart cpanel with command "/usr/local/cpanel/startup"

    It should help you out. :)

    Thanks,
     
  5. bashcpanel

    bashcpanel Well-Known Member

    Joined:
    Apr 15, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Make sure you have added "ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi" line where other almost similar lines are also present.

    For this you can do 1 thing .. open httpd.conf file and search for "cpanel" word you will see other entries start with "ScriptAlias" or "ScriptAliasMatch" and other.

    Thanks,:)
     
  6. Dayu

    Dayu Member

    Joined:
    Aug 13, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Yay! That was great!
    It works now. Thanks.

    Additional question, How can I make it work on /whm too?
    I tried using the same ScriptAlias code but it redirects to port 2082 and not 2087.
     
  7. bashcpanel

    bashcpanel Well-Known Member

    Joined:
    Apr 15, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Greetings Dayu, :)

    Please check these lines are present in httpd.conf .

    =============
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    =============

    If not add them and restart apache.

    Thanks,
     
  8. Dayu

    Dayu Member

    Joined:
    Aug 13, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    That was really great!
    Thanks a lot, everything is working fine now. :D
     
Loading...

Share This Page