SOLVED Can't login to WebMail: "The page isn’t redirecting properly"

G-e-o-r-g-e

Member
Feb 21, 2018
12
2
3
Greece
cPanel Access Level
Root Administrator
Hello...

I go to:

cPanel ==> Email Accounts ==> I find an email account ==> Check email.

I then see the message: "WebMail Login: Logging you in..."

But then the page displays an error:

- - - -
The page isn’t redirecting properly

An error occurred during a connection to [my-domain].com:2096.

This problem can sometimes be caused by disabling or refusing to accept cookies.
- - - -

I haven't disabled or refused to accept cookies.

I have logged out and logged back in. Same thing.

I'm unable to access my emails.

I only have one browser installed (Firefox).

Can something be done about it?

Thanks!
 
Last edited by a moderator:

kodeslogic

Well-Known Member
Apr 26, 2020
240
78
103
IN
cPanel Access Level
Root Administrator
Make sure in Cloudflare DNS zone tab A record for "webmail" entry is set to "DNS Only" and not proxied. After that, you should able to access the webmail with https://webmail.[my-domain].com

You can also directly access webmail by https://hostname:2096
 

G-e-o-r-g-e

Member
Feb 21, 2018
12
2
3
Greece
cPanel Access Level
Root Administrator
Hello, folks - thanks for the help again.

It seems I have made a mistake. There are several addon domains attached to this domain, that use Cloudflare for SSL. However, the main domain itself does not use Cloudflare. Sorry about this.

I was able to login via webmail.[my-domain].com and hostname:2096.

When I selected "horde", I got the same redirection error again.

When I selected "roundcube", I was logged in to the default email account for this domain, and not the one I actually want to access. I couldn't find an option to access another email account.

I feel we are getting closer to a solution.

Thanks!
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,283
536
273
cPanel Access Level
Root Administrator
Just to confirm, you are using the main domain that is not proxied through Cloudflare and you are still not able to log in properly? Could you try moving the .htaccess file out of the way for that domain to see if that resolves the issue?
 

G-e-o-r-g-e

Member
Feb 21, 2018
12
2
3
Greece
cPanel Access Level
Root Administrator
Correct. No Cloudflare for the main domain.

That specific domain is a WordPress multisite installation with hundreds of sites and client sites. Not sure if I should just move the .htaccess file (and move it where?). :)

Maybe it's best I open a ticket about this?

Thanks again.
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,283
536
273
cPanel Access Level
Root Administrator
I'm glad to hear that's working well, although it's always nice to know what the issue is. It's possible an automated overnight update fixed something in cPanel that was causing this, but feel free to open a ticket at anytime if you run into issues in the future so we can check those as soon as possible!