Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't login to Webmail using dovecot master password

Discussion in 'E-mail Discussions' started by Andriy, Jan 13, 2018.

  1. Andriy

    Andriy Registered

    Joined:
    Jan 9, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    kyiv
    cPanel Access Level:
    Root Administrator
    Hello. I have a question. Now I want to enable login to any customer's mailbox without user's password using dovecot master password without using cPanel session IDs.

    I've configured dovecot and tested this config on server without cPanel. All working good: I can login to any mailbox using master password - - Removed-

    I tried to configure dovecot on server with cPanel. Dovecot configured successfully and I can log in with dovecot master password via telnet:
    Code:
    [root@webcloud1 dovecot]# telnet localhost 143
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE NAMESPACE STARTTLS AUTH=PLAIN AUTH=LOGIN] Dovecot ready.
    1 login test@domain.mk.ua/master@domain.mk.ua unencrypted password
    1 OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS THREAD=ORDEREDSUBJECT MULTIAPPEND URL-PARTIAL CATENATE UNSELECT CHILDREN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS BINARY MOVE NAMESPACE NOTIFY COMPRESS=DEFLATE QUOTA] Logged in
    Doveadm auth also working correctly:

    Code:
    [root@webcloud1 dovecot]# doveadm auth test test@domain.mk.ua/master@domain.mk.ua
    Password:
    passdb: test@domain.mk.ua/master@domain.mk.ua auth succeeded
    extra fields:
     user=test@domain.mk.ua
     original_user=master@domain.mk.ua
     auth_user=master@domain.mk.ua
    But when I trying to login with master password via cPanel's webmail, I can't. I get the error: The login is invalid. See attached image.

    I've checked /usr/local/cpanel/logs/login_log and found next records:
    Code:
    [2018-01-14 10:26:33 +0800] info [webmaild] 192.168.60.124 - test@domain.mk.ua-m "POST /login/?login_only=1 HTTP/1.1" FAILED LOGIN webmaild: user password hash is missing from system (user probably does not exist)
    In maillog nothing. So, I have some questions, one answer on it can resolve my issue:
    1. How to connect to user's mailbox directly via dovecot without cPanel's user check?
    2. How enable in cPanel dovecot master password authentication without using cpanel sessions (WHM API 1 Functions - create_user_session - Software Development Kit - cPanel Documentation) ?
    3. How to disable user check?
    So, what must I do? Who have any ideas?
     
    #1 Andriy, Jan 13, 2018
    Last edited by a moderator: Jan 13, 2018
  2. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    27
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    Hi @Andriy,

    I'm afraid this isn't something you would be able to change, as this webmail is served by cpsrvd, which is compiled in; the changes would need to be made in cPanel's core code. I'd recommend submitting a feature request.

    Thanks,
     
Loading...

Share This Page