The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't rainstall/update apache

Discussion in 'EasyApache' started by filth80, Sep 10, 2011.

  1. filth80

    filth80 Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    I had nginx and i uninstalled on one of our servers.Now when i try to restart apache i receive

    "If apache restart reported success but it failed soon after, it may be caused by oddities with mod_ssl.

    You should run /usr/local/cpanel/scripts/ssl_crt_status as part of your troubleshooting process. Pass it --help for more details.

    Also be sure to examine apache's various log files.
    Apache Restart Output:

    Log:
    [Sat Sep 10 13:32:30 2011] [notice] ModSecurity: PCRE compiled version="8.12"; loaded version="8.12 2011-01-15"
    [Sat Sep 10 13:32:30 2011] [notice] ModSecurity: LIBXML compiled version="2.7.8"
    [Sat Sep 10 13:32:31 2011] [notice] SSL FIPS mode disabled
    [Sat Sep 10 13:32:31 2011] [notice] Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/1.0.0-fips FrontPage/5.0.2.2635 mod_bwlimited/1.4 mod_auth_passthrough/2.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
    [Sat Sep 10 13:32:59 2011] [notice] SIGHUP received. Attempting to restart
    [Sat Sep 10 13:33:00 2011] [notice] SSL FIPS mode disabled
    [Sat Sep 10 13:33:00 2011] [notice] Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/1.0.0-fips FrontPage/5.0.2.2635 mod_bwlimited/1.4 mod_auth_passthrough/2.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
    [Sat Sep 10 13:33:32 2011] [notice] SIGHUP received. Attempting to restart
    [Sat Sep 10 13:33:33 2011] [notice] SSL FIPS mode disabled
    [Sat Sep 10 13:33:33 2011] [notice] Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/1.0.0-fips FrontPage/5.0.2.2635 mod_bwlimited/1.4 mod_auth_passthrough/2.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
    [Sat Sep 10 13:34:29 2011] [notice] caught SIGTERM, shutting down !!
    Building global cache for cpanel...Done
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Executing '/scripts/update_apachectl' !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1315654245' !!"

    Also when i try an update/recompile:

    "-- Begin opt 'Mod SuPHP' --
    -- Begin step 'Setting version variable' --
    -- End step 'Setting version variable' --

    -- Begin step 'Patching mod_suphp' --
    Testing patch '../cppatch/01_suphp_paths.patch' -p1...
    patch: **** Can't create file /tmp/poi6TEwQ : No space left on device


    Testing patch '../cppatch/01_suphp_paths.patch' -p0...
    The text leading up to this was:
    --------------------------
    |diff -Nur suphp-0.7.1.orig/src/apache/mod_suphp.c suphp-0.7.1/src/apache/mod_suphp.c
    |--- suphp-0.7.1.orig/src/apache/mod_suphp.c 2007-03-14 09:50:55.000000000 -0500
    |+++ suphp-0.7.1/src/apache/mod_suphp.c 2009-05-04 17:16:38.000000000 -0500
    --------------------------
    File to patch:
    Skip this patch? [y] patch: **** Can't create file /tmp/prD69Qkg : No space left on device

    !! Patch test '../cppatch/01_suphp_paths.patch' failed !!
    !! Restoring original working apache !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Restarting 'httpd' ... !!
    !! Failed to restart Apache. !!
    !! Apache restart failed. Unable to load pid from pid file and no httpd process found in process list.

    If apache restart reported success but it failed soon after, it may be caused by oddities with mod_ssl.

    You should run /usr/local/cpanel/scripts/ssl_crt_status as part of your troubleshooting process. Pass it --help for more details.

    Also be sure to examine apache's various log files.
    Apache Restart Output:

    Log:
    [Sat Sep 10 13:32:30 2011] [notice] ModSecurity: PCRE compiled version="8.12"; loaded version="8.12 2011-01-15"
    [Sat Sep 10 13:32:30 2011] [notice] ModSecurity: LIBXML compiled version="2.7.8"
    [Sat Sep 10 13:32:31 2011] [notice] SSL FIPS mode disabled
    [Sat Sep 10 13:32:31 2011] [notice] Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/1.0.0-fips FrontPage/5.0.2.2635 mod_bwlimited/1.4 mod_auth_passthrough/2.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
    [Sat Sep 10 13:32:59 2011] [notice] SIGHUP received. Attempting to restart
    [Sat Sep 10 13:33:00 2011] [notice] SSL FIPS mode disabled
    [Sat Sep 10 13:33:00 2011] [notice] Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/1.0.0-fips FrontPage/5.0.2.2635 mod_bwlimited/1.4 mod_auth_passthrough/2.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
    [Sat Sep 10 13:33:32 2011] [notice] SIGHUP received. Attempting to restart
    [Sat Sep 10 13:33:33 2011] [notice] SSL FIPS mode disabled
    [Sat Sep 10 13:33:33 2011] [notice] Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/1.0.0-fips FrontPage/5.0.2.2635 mod_bwlimited/1.4 mod_auth_passthrough/2.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
    [Sat Sep 10 13:34:29 2011] [notice] caught SIGTERM, shutting down !!
    Building global cache for cpanel...Done
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    !! Executing '/scripts/update_apachectl' !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1315654245' !!"


    Please help i need desperate help.

    LE: I found out this is because of inodes:

    root@server [~]# df -i
    Filesystem Inodes IUsed IFree IUse% Mounted on
    /dev/md2 30384128 522089 29862039 2% /
    tmpfs 1006668 1 1006667 1% /dev/shm
    /dev/md0 51200 44 51156 1% /boot
    /dev/loop0 128016 127980 36 100% /tmp

    What should i do?
     
    #1 filth80, Sep 10, 2011
    Last edited: Sep 10, 2011
  2. k-planethost

    k-planethost Well-Known Member

    Joined:
    Sep 22, 2009
    Messages:
    199
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Athens Greece
    /dev/loop0 128016 127980 36 100% /tmp
    i think you have issues with /tmp
     
  3. gvard

    gvard Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2003
    Messages:
    195
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Athens/GREECE
    cPanel Access Level:
    DataCenter Provider
    Can't create file /tmp/prD69Qkg : No space left on device


    Clean /tmp and try again.
     
Loading...

Share This Page