The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't receive emails after inputing new MX records for Remote Exchanger

Discussion in 'E-mail Discussions' started by wboustany, Oct 1, 2014.

  1. wboustany

    wboustany Member

    Joined:
    Oct 1, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi there,

    My issue is simple:

    I have a website hosted at reg.u. However I realised emails sent through their servers end up in SPAM folders most of the time. So I moved I went on using Godaddy emailing services and

    1. inputted on Reg.ru CPanel Godaddy's MX records
    2. changed to Remote Exchanger

    However I am now facing a problem:
    a. I can send emails without having them ending up in SPAM folders
    b. I cannot receive emails anymore. Any attempt to send emails to the email address associated to the domain name hosted at reg.ru gets the following message:
    "
    This is an automatically generated Delivery Status Notification.

    Delivery to the following recipients failed.
    "
    c. Oddly enough, when I send an email using the address associated to the domain hosted at reg.ru, but through Godaddy's services (since I inputted MX records), that works well...but replying to it yield the same delivery failure message than above.

    I wonder if there is an additional setting I should have modified in the Panel...I am a bit stuck.

    Any insight would be much appreciated.

    Regards,

    me
     
  2. wboustany

    wboustany Member

    Joined:
    Oct 1, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    UPDATE: here's the technical headers log:

    --------------------------------------------------
    [Removed - Actual Domain Used]

    --------------------------------------------------

    Tried to match it with the stick thread to no avail.

    Anyone kind enough to lend me a hand ?

    Regars,
     
    #2 wboustany, Oct 2, 2014
    Last edited by a moderator: Oct 2, 2014
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please keep in mind that when you use remote MX records, you must create the email accounts on that remote mail server. The email accounts you create on the cPanel server are no longer relevant.

    Thank you.
     
  4. wboustany

    wboustany Member

    Joined:
    Oct 1, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thank you for your prompt response.

    In act I did create the email address. I can even use it to send emails and it works. But I cannot receive emails on it....

    If somone send emails to it he gets the error message previously mentionned.

    On the CPANEL should I change anything else than MX Records ? Should I for example go to the DNS Zone and add an additional (A, or CNAME or whatever) entry there ?

    - - - Updated - - -

    The only thing I did right now on the CPANEL is to input the MX Records provide by Godaddy customer support.

    Is there any change I should also operate on Godaddy's side ?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The MX records are the only settings you have to change, other than selecting "Remote Mail Exchanger" for the domain name. All other aspects of email are handled on the remote mail server, so you must create email accounts and trouble mail issues on that server as opposed to the cPanel server.

    Thank you.
     
  6. wboustany

    wboustany Member

    Joined:
    Oct 1, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Ok thank you for the clarifications. Gonna contact Godaddy again and sort that out with them.
     
  7. wboustany

    wboustany Member

    Joined:
    Oct 1, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Ok finally got it to work....after literally 12 hours of research.

    I have initially set the MX records to:
    0 smtp.secureserver.net
    10 mailstore1.secureserver.net

    Oddly enough here was the issue.

    After discussing with godaddy support I was prompted to change t

    Priority 0: smtp.secureserver.net

    Priority 10: mailstore1.europe.secureserver.net

    again that didn't work, always yield a "no recipient" 550 5.1.1 error

    And then I went on trying, and that a truly a last resort measure:

    0 smtp.europe.secureserver.net
    10 mailstore1.europe.secureserver.net

    AND IT WORKED !

    Complete nonesene for me as for how this last combination works and not the others....If somone can shed some insight that would be appreciated.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You likely need to consult with GoDaddy about why that change worked, as it's only the server names you are changing and that would be under their control.

    Thank you.
     
Loading...

Share This Page