Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Can't receive emails from gmail

Discussion in 'E-mail Discussion' started by danutzu117, Jun 20, 2018.

  1. danutzu117

    danutzu117 Registered

    Joined:
    Jun 20, 2018
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Bucharest
    cPanel Access Level:
    DataCenter Provider
    Hello,

    Recently, the following issue has been occurred on one of my servers:

    I can't receive emails from gmail, but I can send (from yahoo, office 365 or other private domains i can receive and send).

    This problem has been occurred about last week and till now I didn't find a solution.

    Bounce back email (from gmail) looks like this and came after 48 hours in gmail account:

    Delivery incomplete
    There was a temporary problem delivering your message to LEARN MORE

    The response was:

    The recipient server did not accept our requests to connect. Learn more at Fix bounced or rejected emails - Gmail Help [domain.tld. xxx.xxx.209.9: timed out]

    Final-Recipient: rfc822; test_domain@domain.tld
    Action: delayed
    Status: 4.4.1
    Diagnostic-Code: smtp; The recipient server did not accept our requests to connect. Learn more at Fix bounced or rejected emails - Gmail Help
    [domain.tld. xxx.xxx.209.9: timed out]
    Last-Attempt-Date: Tue, 19 Jun 2018 06:20:15 -0700 (PDT)
    Will-Retry-Until: Thu, 21 Jun 2018 05:37:01 -0700 (PDT)



    What I've already searched/tried:

    a). SMTP Status Code 4.1.1 – Email address does not exist. -> the email address exist

    b). Reading google advice at: Fix bounced or rejected emails - Gmail Help
    1. Check for these common mistakes in the email address you're sending to:
      • Quotation marks
      • Dots at the end of the address
      • Spaces before or after an address
      • Spelling errors
    2. Search your contacts for a different address the same person uses
    Checked all of the above points and all of them are OK

    c). Checked WHM » Email » Mail Delivery Reports -> there are NO reports
    from here: can not receive email from gmail

    d). Checked maillog and old maillogs (maillog-20180617, etc.) -> there are NO records for that gmail address.

    e). Checked exim_mainlog and old mainlogs (exim_mainlog-20180617.gz) -> there are NO records for that gmail address.

    f). Checked exim_rejectlog and old rejectlogs (exim_rejectlog-exim_rejectlog) -> there are NO records for that gmail address.

    g). telnet ip 25 -> connected without any issues

    h). running /scripts/mailperm username -> no perm issues (can't receive any emails from gmail)

    i). I've also checked the following things from this post:
    I can send but cannot receive e-mails
    Without any luck, all of them are OK.

    j). This thread pushed me to write on cPanel forum (in lack of any other ideas): Google Groups


    Server config:
    Centos 6 with CloudLinux 6.9 on it
    WHM v70.0.48


    If you have any other ideas, feel free to reply.

    Thanks a lot.
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,758
    Likes Received:
    1,886
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @danutzu117,

    The lack of an entry in /var/log/exim_mainlog suggests Google is unable to connect to your server. Are you using any firewall rules on this system, or a firewall management utility such as CSF?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. danutzu117

    danutzu117 Registered

    Joined:
    Jun 20, 2018
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Bucharest
    cPanel Access Level:
    DataCenter Provider
    Hi,

    Yes, I'm using CSF but same csf.conf/allow/deny files I have on other 32 servers and there I don't have this issue.

    Also in lfd.log I didn't find anything, beside that I've put in csf.allow the followings IPs from gmail:

    173.194.76.26
    74.125.195.27
    108.177.14.27
    172.217.194.27
    108.177.125.27

    Thanks,
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,758
    Likes Received:
    1,886
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @danutzu117,

    Can you open a support ticket so we can take a closer look to see what's happening? You can post the ticket number here and we will link this thread to the ticket.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    1,001
    Likes Received:
    44
    Trophy Points:
    28
    cPanel Access Level:
    Root Administrator
    Can I suggest that you either temporarily disable CSF while you conduct a quick test, or maybe a safer option would be to clear out the CSF deny list.
     
    danutzu117 and cPanelMichael like this.
  6. danutzu117

    danutzu117 Registered

    Joined:
    Jun 20, 2018
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Bucharest
    cPanel Access Level:
    DataCenter Provider
    Hello,

    @Michael -> I'll not make a support ticket, below you'll find the reason :)

    @keat63 -> I didn't think before to post here to disable CSF ... with CSF disabled, emails (from gmail) are coming through.

    I've compared csf.conf from this server with another csf.conf from another server and files are the same and I took the decision to whitelist google ips.

    What I've done to working again, I've searched:

    host smtp.gmail.com
    host mail.gmail.com
    host gmail.com
    host google.com
    host aspmx.l.google.com

    Took the IP classes from google and added into csf.allow and now everything it's OK.

    And reassured that in csf.conf port range 30000:50000 is set, because I've saw in exim log what ranges of ports are used (H=mail-wr0-f173.google.com [209.85.128.173]:46928).

    Thanks a lot for help!
     
    cPanelMichael likes this.
  7. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,758
    Likes Received:
    1,886
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @danutzu117,

    I'm glad to see the issue is now solved. Thank you for sharing the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    danutzu117 likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice