The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't Receive Emails - PERM_FAILURE: SMTP Error (state 9):

Discussion in 'E-mail Discussions' started by anyuzer, Jun 17, 2006.

  1. anyuzer

    anyuzer Registered

    Joined:
    Jun 15, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    So, I wasn't sure where else to stick this. I'm not that new to cpanel, but brand new to whm and dedicated server issues (which I recently have found myself in need of).

    Anyways, I set up an account through whm, set up the website on that account etc. Everything has been going fine so far, not that many hiccups and I think I'm past the worst of it. Finally though I set up some email accounts and then after a day or two without email, I think that maybe something is amiss.

    So I send myself an email through my gmail account, and I receive the following error:

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 550-nz-out-0102.google.com [64.233.162.206] is currently not permitted to relay
    550-through this server. Perhaps you have not logged into the pop/imap server
    550-in the last 30 minutes or do not have SMTP Authentication turned on in your
    550 email client.


    So, just to make sure it's not a gmail specific problem I send myself emails from a variety of accounts. Sure enough, I can't receive emails. So I do a bit of checking around and see somebody suggesting to check my exim_mainlog... which I do. And end up with the following message:

    /var/log/exim_mainlog: line 1: =: No such file or directory
    /var/log/exim_mainlog: line 2: 2006-06-11: command not found
    /var/log/exim_mainlog: line 3: syntax error near unexpected token '('
    /var/log/exim_mainlog: line 3: '2006-06-11 04:02:22 1FpLpj-00020T-3U == root@celeronsuper10.servermatrix.host R=localuser T=local_delivery defer (-29): User 0 set for local delivery transport is on the never_users list'


    ...uh. Okay. At this point, I know my lack of experience is killing me and figure I should see if some gurus can point me in a direction that might help me out.

    So if anybody could identify the issue and knows how I might be able to fix it, it would be appreciated.

    Thanks.

    PS. I've also already tried restarting all of my email associated services, as well as done a /scripts/eximup --force. Also, the only email thing I've had to do on the server so far was do a mbox to maildir conversion, which I'm wondering if that could've caused the problem.
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    I would guess its A DNS issue

    first you need to set up a hostname "celeronsuper10.servermatrix.host" is not one
    set up your root fowarders whm set & mail preferances

    you would want to tail your exim_mainlog or open it in a editor nano or vi
     
  3. anyuzer

    anyuzer Registered

    Joined:
    Jun 15, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the suggestion.

    my hostname I believe is fine (fast.fastsheets.com) and I believe I've set up my root forwarders

    as for tail /var/log/exim_mainlog, it produces the following:

    2006-06-17 17:00:42 1FrkiU-0000d6-Vs Completed
    2006-06-17 17:02:54 exim 4.52 daemon started: pid=3749, -q1h, listening for SMTP on port 25 (IPv4)
    2006-06-17 17:02:54 exim 4.52 daemon started: pid=3754, no queue runs, listening for SMTPS on port 465 (IPv4)
    2006-06-17 17:02:54 Start queue run: pid=3753
    2006-06-17 17:02:54 1FrC6L-0002Zd-No Message is frozen
    2006-06-17 17:02:54 1Fri2I-0004cg-9Z Message is frozen
    2006-06-17 17:02:54 1FrC5j-0002Uz-IG Message is frozen
    2006-06-17 17:02:54 1Fri10-0004cM-9w Message is frozen
    2006-06-17 17:02:54 End queue run: pid=3753
    2006-06-17 17:04:48 H=nz-out-0102.google.com [64.233.162.207] F=<anyuzer@gmail.com> rejected RCPT <ian@fastsheets.com>: nz-out-0102.google.com [64.233.162.207] is currently not permitted to relay through this server. Perhaps you have not logged into the pop/imap server in the last 30 minutes or do not have SMTP Authentication turned on in your email client.


    Which, uh, yeah?
     
  4. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    use tail -f /var/log/exim_mainlog to watch the logs go by


    your DNS servers are missing the A records


    have your data center set up a reverse ptr on your server IP with your hostname it currently points to m3.spamh.com

    check your /etc/localdomains file and make sure your domain is in there
    make sure its not in /etc/remotedomains (if you have one)

    make sure antirelayd is working

    /scripts/fixrelayd should fix it if its broke
     
Loading...

Share This Page