cant recieve any emails but can send?

b0072k1

Well-Known Member
Dec 30, 2004
132
0
166
Glasgow
Hi, i got a problem, my email system on cpanel can send out emails but the system cant recieve any :S any one know like a fix or summit, ive tried reinstall it and such just doseny help
 

King0r

Registered
Dec 11, 2005
1
0
151
Cant recieve but can send mail

Got the same problem here.

In WHM look at the links on the left and find the heading Email then click View Mail Statistics and see what errors you are getting.

1 [email protected] R=lookuphost T=remote_smtp:
SMTP error from remote mail server after MAIL FROM::
host mailin-04.mx.aol.com [205.188.159.217]: 550 REQUESTED
ACTION NOT TAKEN: DNS FAILURE

Mine are SMTP but SMTP servers in the DNS config file are fine.

Any help appreciated.
 

m23

Registered
Dec 11, 2005
2
0
151
Logging in with full email address?

I had a similar problem. My inbox was empty, even though I *know* I had received email (I'll explain in a sec) but my sent box did have email sent. Is that what you're experiencing?

The problem, for me, was related to how I was logging in. Say my email address was [email protected]. I was logging in as username and not seeing any email in my inbox. I wasn't logging in with the full email address. But when I logged in with the full email address, as [email protected], then my inbox DID have mail.

I don't know why cPanel works that way, but it does, apparently. You need to login with your full email address.

I consider this behavior to be a minor problem. If the full email address is required in order for webmail to work, then why isn't there a check when logging in? What does cPanel allow users to login with just their username?
 

selavi

Registered
Aug 25, 2006
1
0
151
this is the good explanation your webmail inbox is empty

ok,you were right;this is the good explanation.i had had the same problem till your post opened my mind.allways i tried to log in with my main username wich i created when i bought my hosting plane, but ,later when i`ve set up my email account i used other user name than may main user account.that`s all.when you try to logg in just use your email as username.
 

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,217
4
193
Minneapolis, MN
selavi and deftech,
You're responding to an old postings. I am sure they fixed their email problems. Thank you!
 

kkentert

Registered
Jun 24, 2006
3
0
151
make sure you have MX records set up. mail.yourdomain.com need to handle mail for yourdomain.com
 

amaranthia

Registered
Feb 1, 2007
1
0
151
Same Problem

I am having the same problem my mx records are fine i can send but i cannot recieve emails i looked in the lock and see these errors.

2007-02-01 17:54:38 1HCTYN-0008HF-Pm ** [email protected] <[email protected]> R=virtual_aliases: no such address here
2007-02-01 17:54:38 1HCTYN-0008HF-Pm Frozen (delivery error message)