Can't remove Addon domains if a security feature is checked in Tweak Settings.

jols

Well-Known Member
Mar 13, 2004
1,110
3
168
Okay, this is a little strange. If I switch off the following in Tweak Settings, as has been recommended by security staff:

Allow other applications to run the cPanel and admin binaries

... and as is now set to "off" by default, then cPanel will not allow addon domains to be removed. Here is the error that is triggered:

Error from park wrapper: This wrapper may only be run from the cpanel binary. This setting can be adjusted in Tweak Settings.

What's really strange about this is that several 3rd party apps such as RVSitebuilder and Fantastico run file with this option set to "off", but cPanel's own addon domain feature will not work????
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
77
308
cPanel Access Level
Root Administrator
That is strange. I attempted to reproduce this on 11.30.1.4 and was unable to.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
38
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello jols,

Please open up a ticket for us to investigate this further on your machine. A ticket may be opened in WHM > Support Center > Contact cPanel or using the link in my signature. If you could also post any the ticket number submitted.

Finally, could you also post any possible errors logging in /usr/local/cpanel/logs/error_log location by tailing the log file when you have that Tweak Setting set to "off" and you try to use the addon domain area:

Code:
tail -fn0 /usr/local/cpanel/logs/error_log
Thanks!