The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't send email from server.

Discussion in 'E-mail Discussions' started by eonstudios, Mar 2, 2011.

  1. eonstudios

    eonstudios Registered

    Joined:
    Mar 2, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I have WHM and Cpanel. Any time I try to send messages from any of the accounts on my server I immediately get a bounceback message (see example below). doesn't matter which account I send through. If i am logged into the server through ssh I cannot ping out side websites.

    ---------------Example bounce back message----------------

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    example@gmail.com
    The mail server could not deliver mail to example@gmail.com. The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <test@domain.org>
    Received: from localhost ([127.0.0.1] helo=209-236-69-188.underconstructionlink.com)
    by server.eonstudios.com with esmtpa (Exim 4.69)
    (envelope-from <test@domain.org>)
    id 1PuwQD-0000kf-IU
    for example@gmail.com; Wed, 02 Mar 2011 17:29:37 -0700
    MIME-Version: 1.0
    Content-Type: text/plain;
    charset=UTF-8;
    format=flowed
    Content-Transfer-Encoding: 7bit
    Date: Wed, 02 Mar 2011 17:29:36 -0700
    From: <test@domain.org>
    To: <example@gmail.com>
    Subject: test
    Message-ID: <6f0649586de7a041ae0ce64b71b81447@domain.org>
    X-Sender: test@domain.org
    User-Agent: Roundcube Webmail/0.4.2

    test
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Do you have a firewall running? If so, please disable the firewall as your first measure of troubleshooting.

    Next, check your /etc/resolv.conf file and use the following resolvers to see if that might be the issue:

    Code:
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    Place these above the existing resolvers. They are Google's public DNS resolvers that can be used if your existing ones aren't working right.

    After doing the above, try a telnet to port 25 using the following commands:

    Code:
    telnet localhost 25
    telnet 74.125.67.27 25
    The second command is the primary MX for gmail when I run an exim -bt on my gmail address:

    Code:
      router = lookuphost, transport = remote_smtp
      host gmail-smtp-in.l.google.com      [74.125.67.27]  MX=5
      host alt1.gmail-smtp-in.l.google.com [74.125.47.27]  MX=10
      host alt2.gmail-smtp-in.l.google.com [74.125.113.27] MX=20
      host alt3.gmail-smtp-in.l.google.com [209.85.229.27] MX=30
      host alt4.gmail-smtp-in.l.google.com [74.125.43.27]  MX=40
     
  3. eonstudios

    eonstudios Registered

    Joined:
    Mar 2, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for your quick response. It was the resolv.com file that needed to be set. I really appreciate the help.

    Jon Wardle
     
  4. chrisangel

    chrisangel Registered

    Joined:
    Feb 5, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    aw ya its really nice piece of information regarding the issue which is that we can`t send email from server..!! its realy appreciating for giving your time here.
     
Loading...

Share This Page