SOLVED Can't send or receive emails

SynteX

Member
Aug 8, 2013
6
0
1
cPanel Access Level
Root Administrator
Hi there,

I have a big problem i can't send or receive emails on my brand new server.
If i take a look at the cpanel mail delivery logs this is what i get:

- Every mail -> in progress

The only things i know is that i instelled clamV because secuirity advisor wanted it.
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,880
2,256
463
Hello,

Could you search for one of the messages in /var/log/exim_mainlog and let us know the output? EX:

Code:
exigrep [email protected] /var/log/exim_mainlog
Ensure to remove real domain names and IP addresses when pasting the output.

Thank you.
 

SynteX

Member
Aug 8, 2013
6
0
1
cPanel Access Level
Root Administrator
Hello,

Could you search for one of the messages in /var/log/exim_mainlog and let us know the output? EX:

Code:
exigrep [email protected] /var/log/exim_mainlog
Ensure to remove real domain names and IP addresses when pasting the output.

Thank you.
Note that the diskspace error is fixed. Since we've added a new SSD and moved the partitions.
There is now enough diskspace also the account is created after this is done!

[Removed - Please paste the output to the thread in CODE tags]
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,880
2,256
463
Error in system filter: internal problem in system filter: failure to transfer data from subprocess: status=0100 readerror='No such file or directory'
Hello,

This error message can occur if the permissions on the Exim binary are invalid. You can check the permissions with the following command:

Code:
stat /usr/sbin/exim
If they are not set to 4755, you can run the following command to correct this:

Code:
chmod 4755 /usr/sbin/exim
Queued email should then begin to send on the next delivery attempt.

Thank you.
 

SynteX

Member
Aug 8, 2013
6
0
1
cPanel Access Level
Root Administrator
Hello,

This error message can occur if the permissions on the Exim binary are invalid. You can check the permissions with the following command:

Code:
stat /usr/sbin/exim
If they are not set to 4755, you can run the following command to correct this:

Code:
chmod 4755 /usr/sbin/exim
Queued email should then begin to send on the next delivery attempt.

Thank you.
I am affraid it didn't did the trick.

I executed the command's and the permissions are good also did the chmod again in order to be sure.

But when trying to send a new mail the same error has been logged:
Code:
2017-07-13 21:56:38 1dVdgU-00028A-6N Error in system filter: internal problem in system filter: failure to transfer data from subprocess: status=0100 readerror='No such file or directory'
Here:

Code:
[[email protected] ~]# stat /usr/sbin/exim
  File: `/usr/sbin/exim'
  Size: 1253328         Blocks: 2448       IO Block: 4096   regular file
Device: 812h/2066d      Inode: 10388       Links: 1
Access: (4755/-rwsr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2017-07-13 21:56:38.814000014 +0200
Modify: 2017-06-21 22:43:43.000000000 +0200
Change: 2017-07-13 21:55:32.555000006 +0200
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,880
2,256
463
Hello,

Could you open a support ticket using the link in my signature so we can take a closer look?

Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,880
2,256
463
Hello,

To update, it looks like this issue stemmed from the use of the nosuid mount option on the /usr partition. This mount option prevents Exim from working properly.

Thank you.