Cant send to one domain (sometimes)

InternetPEI

Well-Known Member
May 26, 2003
102
0
166
About half the email to this one server in new zealand are failing. This has been working on and off since I did a server switch around Nov 01. I have new ips.

Any suggestions? I emailed them back in early nov and they said they are running strict rules on their mail server for spam. The emails sent to them are to 2 clients and none of my ips were listed in any spam lists..

Anything I can do on my end to help make these go through better?

Thanks Jason


Message 1GpzT0-0000Az-T3 is not frozen
delivering 1GpzT0-0000Az-T3
Connecting to mail.ps.gen.nz [202.49.233.1]:25 ... connected
SMTP<< 220 apollo.ps.net.nz ESMTP Sendmail 8.13.4/8.13.4/Debian-3sarge3; Sun, 3 Dec 2006 11:21:17 +1300; (No UCE/UBE) logging access from: MYSERVER(OK)-MYSERVER [MY IP]
SMTP>> EHLO MYSERVER
SMTP<< 250-apollo.ps.net.nz Hello MYSERVER [MY IP], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-EXPN
250-VERB
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-DELIVERBY
250 HELP
SMTP>> MAIL FROM:<myclient> SIZE=3680
SMTP>> RCPT TO:<persontheyaresendingto>
SMTP>> DATA
SMTP<< 250 2.1.0 <myclient>... Sender ok
SMTP<< 451 4.1.8 Domain of sender address (myclient) does not resolve
SMTP<< 503 5.0.0 Need RCPT (recipient)
SMTP>> QUIT
LOG: MAIN
== persontheyaresendingto R=lookuphost T=remote_smtp defer (-44): SMTP error from remote mail server after RCPT TO:<persontheyaresendingto>: host mail.ps.gen.nz [202.49.233.1]: 451 4.1.8 Domain of sender address myclient does not resolve
Return to Mail Queue
 

celliott

Well-Known Member
Jan 2, 2006
460
0
166
United Kingdom
This answers your question:

SMTP<< 451 4.1.8 Domain of sender address (myclient) does not resolve

Make sure that the sender domain exists and appropriate DNS entries exist on your server.