The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cant set exim to use IP of the domain instead of main IP

Discussion in 'E-mail Discussions' started by sspitfire, Mar 5, 2011.

  1. sspitfire

    sspitfire Active Member

    Joined:
    Mar 5, 2011
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    I need to create new account in WHM with new domain and IP. I create it and it automaticly assigns the next free IP of the VPS to the domain. On that new account I install Interspire. I go to WHM and configure exim to automatically send outgoing mail from the account’s IP address instead of the main IP address. But the email still comes from the main IP when I check the header. A friend of mine has done it exactly this way without editing any config files and it works for him and he is on the same hosting provider as me. Any suggestions?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    How are these emails being sent? If a script, scripts using sendmail will still use the main server IP to send emails as it is bypassing the exim configuration settings.
     
Loading...

Share This Page