The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't set normal shell

Discussion in 'Security' started by shacker23, Mar 9, 2010.

  1. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    I'm having a problem with the "Manage Shell Access" feature in WHM. I can set a user to Jail Shell or None. If I set a user to Normal Shell, it says "Saved" as if it worked. But if I return to the panel a second later, the user is back on Jail Shell.

    If that user makes an ssh connection, they get:

    -jailshell: fork: Resource temporarily unavailable

    This problem just started, and I'm not sure what's changed to cause it. Any idea where to look? Thanks.
     
  2. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    Also, I've tried turning Shell Fork Bomb Protection off and then on again. The problem persists regardless what state that setting is in.
     
  3. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    For the archives, I finally did get this fixed. Here's how:

    1) Went into Tweak Settings and disabled "Use jailshell as the default shell for all new accounts and modified accounts"

    2) Disabled Shell Fork Bomb protection (not needed - this server handles only highly trusted accounts, though I wouldn't mind being able to leave it on if I could).

    But normal shells are working again.
     
  4. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Experienced this as well and find it very irritating.

    jailshell as default for new or modified accounts is good, but if I have to enabled normal shell I shouldn't have to disable the option and disable shell fork bomb protection.

    (wanting to enable normal shell just for a cpanel support ticket investigation)
     
  5. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    FYI: For future reference I suppose -- edit the /etc/passwd file

    All you really need to do is simply change the shell to /bin/bash for the user that you want to have full SSH access.

    The "chsh" command in SSH will do the same thing for you as well
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This is currently a bug within the product. When Use jailshell as the default shell for all new accounts and modified accounts is enabled the Manage Shell Access interface will only set a user's shell to jailed or noshell. This matter is reported to the developers and should be addressed.
     
  7. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    Thanks for the response Kenneth. Good to know it's not me. :)
    We'll be on the lookout for an update.
     
  8. JamieW

    JamieW Member

    Joined:
    May 15, 2006
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Yes, I just ran into this too. I didn't need to change the fork bomb setting. I found when the new/modified shell setting was set to jailed, and then you managed shell access, you could set it to normal, but at the bottom it'd tell you the "normal shell" was set to the jailshell. So of course setting an acct to normal was also setting it to jailed. And when you came back and looked at the settings, it shown them all as jailed again. Turn off the new/modified jail shell setting. Then at the bottom of the manage shell access, you'll see the normal shell is actually a real shell. Then it all works as normal.

    And this is fine for me, as I don't want _modified_ accounts changing their access, just new ones. So I'll leave that off anyways, and know when I set up a new acct to go in and make sure it is set to jailed, if that's what I want.

    So thanks for the pointer, or I might not have considered to change that setting!
     
  9. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    This particular function in WHM has been a little buggy for quite some time ...

    If you edit the "/etc/passwd" file or use "chsh" command to set the shell for user's manually then you can be a lot more confident that everything is configured correctly for the user account(s) in question.
     
  10. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    LMAO .... apparently I'm putting in too many hours --- posted twice :p
     
Loading...

Share This Page