Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Can't stop exim

Discussion in 'E-mail Discussion' started by sspitfire, May 2, 2013.

  1. sspitfire

    sspitfire Active Member

    Joined:
    Mar 5, 2011
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    51
    Hi. I need to stop exim. I have unchecked it in WHM services section. service exim status says: exim is stopped. I tried disabling chkservd but it seems I dont have it installed at all - its not in /etc/init.d The problem is I see in gmail header: Received: from mta by xxxxxx.net with local (Exim 4.80)
    Does it mean its still using exim to send mail ? I need to use another mta. How do i disable exim ?
    thanks
     
  2. storminternet

    storminternet Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    460
    Likes Received:
    0
    Trophy Points:
    66
    cPanel Access Level:
    Root Administrator
    Stop the service from shell using command
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sspitfire

    sspitfire Active Member

    Joined:
    Mar 5, 2011
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    51
    I tried this but still in the header I can see exim.
     
  4. storminternet

    storminternet Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    460
    Likes Received:
    0
    Trophy Points:
    66
    cPanel Access Level:
    Root Administrator
    Use kill command to kill the exim process ids appearing in process table.
    kill -9 pid
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. sspitfire

    sspitfire Active Member

    Joined:
    Mar 5, 2011
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    51
    I dont see it in the process table. also when i try to stop it i get: shutting down exim [FAILED]
     
  6. simonas

    simonas Well-Known Member

    Joined:
    Apr 21, 2013
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lithuania
    cPanel Access Level:
    Root Administrator
    That means it's already down. No?
     
  7. cPanelJared

    cPanelJared Technical Analyst

    Joined:
    Feb 25, 2010
    Messages:
    1,835
    Likes Received:
    21
    Trophy Points:
    143
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    If you have monitoring enabled, chservd will check Exim every five minutes and start it if it is stopped. To prevent this from happening, disable both the Exim service and monitoring for Exim in Home » Service Configuration » Service Manager.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice