The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't Transport Backups to Amazon S3

Discussion in 'Data Protection' started by GwenTheHen, Jan 29, 2016.

  1. GwenTheHen

    GwenTheHen Member

    Joined:
    Oct 13, 2015
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Reseller Owner
    Hello. I don't seem to be able to upload backups to the Amazon S3 service. I have the backups set in WHM, and they are linked to my Amazon S3 account (which has been validated). The system is able to backup to the server fine, but nothing shows up in Amazon. The end of the backup log shows this:

    [2016-01-29 15:08:43 +0000] info [backup] Queuing daily backup copy for transport
    [2016-01-29 15:08:43 +0000] info [backup] Queuing transport of file: /backup/2016-01-29/accounts/domain.tar.gz
    [2016-01-29 15:08:54 +0000] info [backup] Queuing prune operation for remote destination daily backups
    [2016-01-29 15:08:54 +0000] info [backup] Queuing transport reporter
    [2016-01-29 15:08:54 +0000] info [backup] Completed at Fri Jan 29 15:08:54 2016
    [2016-01-29 15:08:54 +0000] info [backup] Final state is Backup::Success (0)
    [2016-01-29 15:08:54 +0000] info [backup] Sent Backup::Success notification.

    I then get this issue in the transporter log:

    S3 Backups devmoduscouk Unable to send “/backup/2016-01-29/accounts/domain.tar.gz” to destination “S3 Backups”

    I don't seem to be able to get any more info from the logs (although I may be missing something).

    Can anyone help?
     
    #1 GwenTheHen, Jan 29, 2016
    Last edited by a moderator: Jan 29, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Is there no additional information in the transport log before or after this line?

    Thank you.
     
  3. GwenTheHen

    GwenTheHen Member

    Joined:
    Oct 13, 2015
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Reseller Owner
    Yes, that's literally it! However, the overnight backups seem to have worked! I just can't force a manual one for some reason. Is that anything to worry about?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Have you tried forcing a backup generation again since the automatic backup generation completed? You can do so via:

    Code:
    /usr/local/cpanel/bin/backup --force
    Thank you.
     
Loading...

Share This Page