noimad1

Well-Known Member
Mar 27, 2003
626
0
166
Ok, I am having more serious problems then I thought on one of my servers. First, I noticed I couldn't access my "service status" button. When I click on it, it just sits there and sits there.

So today I try to update cpanel with no luck. I even tried upcp --force with no luck??

So tonight I get the apache security warning. I click on update and it just sits there on this:

Building Apache Config.....Done
Downloading and compiling apache+modules....

Creating directory buildapache


My other two servers updated right away.....Anyone have any ideas on what could be happening here?
 

myrem

Well-Known Member
Jul 14, 2002
93
0
156
I think the license server(s) are down? I'm having the same issues... (no 'service status' screen will load and 'upcp' just sits there and does nothing at all).
 

myrem

Well-Known Member
Jul 14, 2002
93
0
156
thaphantom said:
do a /scripts/updatenow and try again.
No go. (yes, updatenow runs ... but upcp just hangs)... I'm assuming that it is related to the 'service status' hanging as well in whm...
 

myrem

Well-Known Member
Jul 14, 2002
93
0
156
;; QUESTION SECTION:
;layer1.cpanel.net. IN A

;; ANSWER SECTION:
layer1.cpanel.net. 9344 IN A 69.72.164.150

;; AUTHORITY SECTION:
cpanel.net. 9595 IN NS w.cpanel.net.
cpanel.net. 9595 IN NS p.cpanel.net.
 

myrem

Well-Known Member
Jul 14, 2002
93
0
156
First off, I'm on WHM 9.4.0 cPanel 9.4.1-E91 RedHat Enterprise 3 - WHM X v3.1.0

'Service Status' only 'hangs' in WHM. In Cpanel, it loads.

When doing a manual (shell) upcp I get no error... It just sits there without displaying anything. If I cntl-C it, I get
Code:
PHP version file is up to date
PHP version file is up to date
Doing a manual update...
Cpanel updates are coming from layer2.cpanel.net
Checking /dev/sda....OK
Checking /dev/sdb....OK
x - creating lock directory
x - SKIPPING /usr/local/lib/php.ini (file already exists)
And it then just sits there forever. cntl-C won't break out of it.
 

PeteC

Well-Known Member
May 8, 2003
106
1
166
Texas
I've got the same exact problem on one server. Just to let you know you're not alone... I think it's time for a support ticket.
 

PeteC

Well-Known Member
May 8, 2003
106
1
166
Texas
Ticket # 66042

It might not hurt for you to submit a ticket too, noimad1, so they know it's not an isolated incident.
 

noimad1

Well-Known Member
Mar 27, 2003
626
0
166
PeteC said:
Ticket # 66042

It might not hurt for you to submit a ticket too, noimad1, so they know it's not an isolated incident.
Ok....ticket # 66143

Damion
 
Last edited:

arbuzas

Member
Apr 10, 2004
23
0
151
I update cPanel (WHM 9.4.0 cPanel 9.4.1-E124) and then it told me that I have to update apache (php) because it's insecure bla bla, When I tray to do this, after update apache don't start (httpd has failed, please contact the sysadmin.), what a heck is going are? :mad: :mad: :( :confused:
 
Last edited:

arbuzas

Member
Apr 10, 2004
23
0
151
I just update apache from whm if cpanel can't build normal update script then it's not my fault.
 

liquidcherry

Well-Known Member
Jan 20, 2004
60
0
156
easyapache?

hi arbuzas,

i guess your apache was updated in between the serverdowns by RHN....
Unless this problem is gone maybe you could try to restore a recent backup,i know that in the backups are some apache files....and also conf files....it could reset apache,at least i know that the httpd.conf is in the backups
I am not a " Server Admin" what daphanta suggested (except my own server ) and this is just an idea,you do it own your own risk,dont blaim me if it is still not working
(Besides that,what do you have to loose? )
Dont get frustrated , but it isnt directly the fault from cpanel neither yours.....

Or,if you have SSH you could use in the scripts folder the easyapache script......
path: /scripts --> ./easyapache (again,works only when the RHN Servers are back online)

let me know


Frank
 

arbuzas

Member
Apr 10, 2004
23
0
151
I bring back PHP 4.3.3 and now working fine but cPanel say "You are running an insecure apache setup. You should run /scripts/easyapache or if you are running cPanel 7.1.9 or later (click here) to upgrade to a newer version as soon as possible to avoid your system being compromised." What a fu*k. I know it's insecure but how update it I view at cPanel forum and see thet I'm not the only the suffering from this problem read Topic:Updating PHP?; /scripts/easyapache issue; Building PHP 4.3.8 Fail ! Please help !; can't update apache or cpanel; and etc...
 

arbuzas

Member
Apr 10, 2004
23
0
151
I want to update to PHP 4.3.8 now I have 4.3.3 is PHP5 stabile?
 
Last edited:

liquidcherry

Well-Known Member
Jan 20, 2004
60
0
156
hmmmm thats a good question :)

let me answer with an question:

is windows secure? :)

just kidding as far i know it just came out today so there will be for sure something in the future.....but at least its more secure then 4.3.3.......or 4.3.7(besides that iam still on 4.3.7 and dont get any security messages)
But maybe to try again with the 4.3.8 i answered in http://forums.cpanel.net/showthread.php?t=25056 how to try to get recompile php done with WHM,it worked for me once....

Let me know

Frank
 

noimad1

Well-Known Member
Mar 27, 2003
626
0
166
Sinewy said:
Have you got BIND dns server on your server?

if you do, modify your resolver config (/etc/resolv.conf) so it has only 127.0.0.1 as the nameserver.

that could be the problem.
Yea, I think I am going to wait for resoultion on my ticket that I submitted before i start going in and poking around. I tend to do more harm then good sometimes...