PeteC

Well-Known Member
May 8, 2003
106
1
166
Texas
cPanel Support Resolution

cPanel support found some hung rpm processes. Here is the reply they gave me (no guarantees of course):

It appears you had a few stuck rpm processes. I did the following:

rm -f /var/lib/rpm/__*
rpm --rebuilddb
rm -f /usr/local/cpanel/cpanel
/scripts/updatenow
/scripts/upcp --force
/usr/local/cpanel/startup

And cPanel has been resynced.
 

noimad1

Well-Known Member
Mar 27, 2003
626
0
166
PeteC said:
cPanel support found some hung rpm processes. Here is the reply they gave me (no guarantees of course):

It appears you had a few stuck rpm processes. I did the following:

rm -f /var/lib/rpm/__*
rpm --rebuilddb
rm -f /usr/local/cpanel/cpanel
/scripts/updatenow
/scripts/upcp --force
/usr/local/cpanel/startup

And cPanel has been resynced.
They said they found hung processon on mine as well. Said I should reboot the machine and see if that helps. So I am going to do the reboot a little later tonight....
 

noimad1

Well-Known Member
Mar 27, 2003
626
0
166
noimad1 said:
They said they found hung processon on mine as well. Said I should reboot the machine and see if that helps. So I am going to do the reboot a little later tonight....
Ok, so after the reboot the easyapache ran without any problems....service status now shows...yay!
 

myrem

Well-Known Member
Jul 14, 2002
93
0
156
PeteC said:
cPanel support found some hung rpm processes. Here is the reply they gave me (no guarantees of course)
This was my problem as well. I killed the hung rpm processes and then upcp worked. Service Status in WHM works again as well.

Thanks, everyone.
 

ljprevo

Well-Known Member
Apr 15, 2003
67
0
156
I am having a serious problem updating one of my servers. It gets to

"portsentry is up to date" and then it just sits there. Can someone help?
 

ljprevo

Well-Known Member
Apr 15, 2003
67
0
156
Went to go put a ticket in with Cpanel and it said

"License expired
You are not eligible for support because your license is listed as expired in our records"

BUT

when I do the lookup of the license I get

"1 ##.###.###.### using package EV1SERVERS-INTERNAL and is licensed though: Everyones Internet, LTD. (active on: 2004-05-19 14:33:40, group: Ev1Servers) and is active. "

What the heck is with this, I CAN'T SUBMIT A TICKET WITH CPANEL!!!!!!!!
 

jrehmer

Well-Known Member
Apr 10, 2003
286
0
166
Denver, CO
This all has to do with RHN server's being down, atleast for the RedHat clients.

Try doing an up2date -l right now, and I guarantee, you won't get anywhere, it will just hang. Hit CTRL-C and hold it down a few seconds and it will tell you there was an error communicating with the server, this is because RHN is currently experiencing some wild problems. This was communicated to me via EV1 Servers support team.

They said scripts such as upcp and easyapache will not work while the RHN servers are down.
 

ljprevo

Well-Known Member
Apr 15, 2003
67
0
156
It has been like this for days. I do that and that is just sitting there.

I have to get this server updated, is there any other way?
 

jrehmer

Well-Known Member
Apr 10, 2003
286
0
166
Denver, CO
ljprevo said:
It has been like this for days. I do that and that is just sitting there.

I have to get this server updated, is there any other way?

Yes run two SSH sessions, run "/scripts/upcp --force" in one

In the other whenever the upcp starts to hang do a "ps aux | grep up2date" in the other, kill all those up2date processes, and the installation and sync of cpanel will continue, I have done, and tested this myself just now.

www.blueworldhosting.com
[email protected]
 

ljprevo

Well-Known Member
Apr 15, 2003
67
0
156
Not having any luck. The server is running for now, I will be back after lunch and try again.

I just want to let you know I appreciate your help.
 

ljprevo

Well-Known Member
Apr 15, 2003
67
0
156
Ok, got this to work, but I had to keep killing the up2dat process.

However I wrote Red Hat and they claim the RHN is not down.

----- Original Message -----
From: "Red Hat Customer Service" <[email protected]>
Sent: Friday, July 16, 2004 3:26 PM
Subject: RE: Down [REF:4090310752]


Greetings,

Thank you for your email.

The Red Hat network is working fine, we do not have any problems with it as of now. Feel free to contact us about your problem with Red Hat Network so that we can check upon your entitlements and figure out the possible problems.

Email: [email protected]
Phone: 1-888-redhat1 ext. 41121

Sincerely,

Ian
Customer Service
Red Hat, Inc.
 

jrehmer

Well-Known Member
Apr 10, 2003
286
0
166
Denver, CO
ljprevo said:
Ok, got this to work, but I had to keep killing the up2dat process.

However I wrote Red Hat and they claim the RHN is not down.

----- Original Message -----
From: "Red Hat Customer Service" <[email protected]>
Sent: Friday, July 16, 2004 3:26 PM
Subject: RE: Down [REF:4090310752]


Greetings,

Thank you for your email.

The Red Hat network is working fine, we do not have any problems with it as of now. Feel free to contact us about your problem with Red Hat Network so that we can check upon your entitlements and figure out the possible problems.

Email: [email protected]
Phone: 1-888-redhat1 ext. 41121

Sincerely,

Ian
Customer Service
Red Hat, Inc.

ARE YOU WITH EV1???? I have a server at EV1 and I cannot access RHN either, and I got the same response, although EV1 is telling me RHN is down.
 

ljprevo

Well-Known Member
Apr 15, 2003
67
0
156
Yes, I am with EV1

I wonder, Is Red Hat blocking the EV1 network?

I sent an email back to Red Hat telling them what is up.
 

jrehmer

Well-Known Member
Apr 10, 2003
286
0
166
Denver, CO
ljprevo said:
Yes, I am with EV1

I wonder, Is Red Hat blocking the EV1 network?

I sent an email back to Red Hat telling them what is up.
I just got a reply from EV1 saying that yes EV1 had an internal problem and its fixed, and it seems to be working fine for me now.
 

ljprevo

Well-Known Member
Apr 15, 2003
67
0
156
I jumped the gun on this.

Here is the error I am getting

[email protected] [~]# up2date -l
Traceback (most recent call last):
File "/usr/sbin/up2date", line 1190, in ?
sys.exit(main() or 0)
File "/usr/sbin/up2date", line 669, in main
up2dateAuth.updateLoginInfo()
File "up2dateAuth.py", line 141, in updateLoginInfo
File "up2dateAuth.py", line 117, in login
up2date_client.up2dateErrors.AbuseError:
Error Message:
Abuse of Service detected for server ###.###.###.### (1004596435)
Error Class Code: 49
Error Class Info:
You are getting this error because RHN has detected an abuse of
service from this system and account. This error is triggered when
your system makes too many connections to Red Hat Network. This
error can not be triggered under a normal use of the Red Hat Network
service as configured by default on Red Hat Linux.

The Red Hat Network services for this system will remain disabled
until you will reduce the RHN network traffic from your system to
acceptable limits.

Please log into RHN and visit https://rhn.redhat.com/help/contact.pxt
to contact technical support if you think you have received this
message in error.
 
Last edited: