Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Can't update cPanel due to MySQL conflicts

Discussion in 'General Discussion' started by DigitalComunic, Jul 24, 2018.

  1. DigitalComunic

    Joined:
    Jan 17, 2009
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Hello.

    I'm working on a VPS that is running cpanel, cloudlinux and mysql governor. The MySQL version is cl-MySQL56 instead of the default MySQL Cpanel

    I'm trying to upgrade Cpanel to v72, but it's giving block due to conflicts between Cpanel-mysql56 and CL-Mysql56.

    This is a bit of error message.
    I thought of removing the mysql governor, but in this VPS there are some scripts that needs mysql version 5.6. So, it would be better if I could upgrade the Cpanel with the mysql governor as it stands now. And I don't know if removing the MySQL governor will cause MySql version 5.7 will be installed in Cpanel, this would be dangerous I think, for the scripts and databases.

    I tried to update yum, and /usr/local/cpanel/scripts/check_cpanel_rpms --fix command, and tried RPM Installation Failures - cPanel Knowledge Base - cPanel Documentation procedures, all without success.

    Any tip for doing this Cpanel update? I will appreciate any help.

    Greetings.
     
  2. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,212
    Likes Received:
    159
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @DigitalComunic


    This is occurring because you have a CloudLinux and a cPanel RPM of the same type. Can you please run the following via SSH:

    Code:
    rpm -qa |grep MySQL56-server-5.6.39
    From what it sounds like the MySQL56-server-5.6.39-1.cp1162.x86_64 package needs to be removed
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DigitalComunic

    Joined:
    Jan 17, 2009
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Hello cPanelLauren, thank you by your support.

    The response is:
    I believe you're right but I need some direction to remove the conflict package.
     
  4. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,212
    Likes Received:
    159
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @DigitalComunic

    Actually I was anticipating seeing the cPanel provided rpm installed. You are indeed running CloudLinux correct? If so, can you show me the repositories you have available:

    Code:
    yum repolist
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. DigitalComunic

    Joined:
    Jan 17, 2009
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Off course, here's the result

    Code:
    [root@servidor3 ~]# yum repolist
    Loaded plugins: fastestmirror, rhnplugin, universal-hooks
    This system is receiving updates from CLN.
    Loading mirror speeds from cached hostfile
     * EA4: 185.69.232.245
     * cpanel-addons-production-feed: 185.69.232.245
     * cloudlinux-x86_64-server-7: cl-mirror.fr.planethoster.net
    repo id                                         repo name                                 status
    !EA4/7/x86_64                                   EA4 ( EasyApache 4 )                       2,227+417
    !cpanel-addons-production-feed/7/x86_64         cPanel Addons Production Feed                     51
    !cl-ea4/7/x86_64                                CloudLinux 7 EasyApache4                      12,939
    !cl-mysql-meta/7/x86_64                         cl-mysql                                          51
    !cloudlinux-imunify360/7/x86_64                 CloudLinux-7 - Imunify360                        533
    cloudlinux-x86_64-server-7                      CloudLinux Server 7 x86_64                41,313+379
    !cpanel-plugins                                 cPanel Plugins project (CentOS 7)                106
    repolist: 57,220
    [root@servidor3 ~]#
    And yes, running Cloudlinux with mysql governor.
     
    #5 DigitalComunic, Jul 25, 2018
    Last edited: Jul 25, 2018
  6. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,212
    Likes Received:
    159
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @DigitalComunic

    Because I don't feel comfortable telling you to remove that package without seeing the system and because the repositories look fine, I think it might be best to handle this in a support ticket. Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. DigitalComunic

    Joined:
    Jan 17, 2009
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Hello CpanelLauren, sorry my delay.

    Because it is a datacenter partner of the cpanel, I had to first contact their support but it did not solve.
    I opend the ticket 9998773 at Cpanel support now.

    Thank you for the help.
     
  8. DigitalComunic

    Joined:
    Jan 17, 2009
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Hello.
    After a precisely work of support specialist, the issue is solved and conflict removed. Now Cpanel is updating well

    I appreciated your orientation CpanelLauren

    Best regards.
     
  9. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,212
    Likes Received:
    159
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @DigitalComunic

    Thank you for opening the ticket, I just checked on it and it would appear that our Analyst was able to resolve the issue by first running:
    Code:
    /scripts/check_cpanel_rpms
    And then adding mysql as unmanaged in
    Code:
    /var/cpanel/rpm.versions.d/local.versions 
    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice