Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Can't update profiles with EasyApache4

Discussion in 'EasyApache' started by pablostevens, Mar 6, 2018.

  1. pablostevens

    pablostevens Registered

    Joined:
    Mar 6, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mississauga, Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Can't update profiles with EasyApache4.

    Updating profiles (ie: adding a new PHP option, never starts and never finishes).

    I've done yum check with the following outpout:

    Loaded plugins: fastestmirror, universal-hooks
    32:bind-libs-9.8.2-0.62.rc1.el6_9.5.x86_64 is a duplicate with 32:bind-libs-9.8.2-0.62.rc1.el6_9.4.x86_64
    ea-apr-1.5.2-9.9.1.cpanel.x86_64 is a duplicate with ea-apr-1.5.2-8.8.6.cpanel.x86_64
    ea-apr-1.5.2-9.9.2.cpanel.x86_64 is a duplicate with ea-apr-1.5.2-9.9.1.cpanel.x86_64
    ea-apr-util-1.5.2-13.13.12.cpanel.x86_64 is a duplicate with ea-apr-util-1.5.2-13.13.11.cpanel.x86_64
    ea-apr-util-1.5.2-13.13.13.cpanel.x86_64 is a duplicate with ea-apr-util-1.5.2-13.13.12.cpanel.x86_64
    ea-php70-libc-client-2007f-11.11.1.cpanel.x86_64 is a duplicate with ea-php70-libc-client-2007f-10.10.1.cpanel.x86_64
    libblkid-2.17.2-12.28.el6_9.2.x86_64 is a duplicate with libblkid-2.17.2-12.28.el6_9.1.x86_64
    libuuid-2.17.2-12.28.el6_9.2.x86_64 is a duplicate with libuuid-2.17.2-12.28.el6_9.1.x86_64
    procps-3.2.8-45.el6_9.1.x86_64 is a duplicate with procps-3.2.8-45.el6.x86_64
    samba-common-3.6.23-46el6_9.x86_64 is a duplicate with samba-common-3.6.23-45.el6_9.x86_64
    samba-winbind-clients-3.6.23-46el6_9.x86_64 is a duplicate with samba-winbind-clients-3.6.23-45.el6_9.x86_64
    samba-winbind-clients-3.6.23-46el6_9.x86_64 has missing requires of samba-winbind = ('0', '3.6.23', '46el6_9')
    Error: check all

    I've tried the:
    package-cleanup --cleandupes

    It doesn't get rid of the dupes. The other problem is with Samba can't update because it requires a previous version. I've tried to just yum update samba, but I get the dependency error again.

    I'm kind of new to managing a VPS, can someone help me with how to clean the above mess?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,870
    Likes Received:
    1,811
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    It looks like duplicate RPMs are installed on your server. For the cPanel RPMs, you can use the following command:

    Code:
    /scripts/autorepair fix_duplicate_cpanel_rpms
    For your system RPMs, first check to see which YUM repo files you are using in the following directory:

    /etc/yum.repos.d/

    Are you using any custom YUM repos that do not come standard with CentOS?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. pablostevens

    pablostevens Registered

    Joined:
    Mar 6, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mississauga, Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Thanks for your help. I ran the fix_duplicate command and it ran smoothly, but didn't change yum check output.

    Here's the content of my yum.repos.d directory.

    CentOS-Base.repo CentOS-Debuginfo.repo CentOS-fasttrack.repo CentOS-Media.repo CentOS-Vault.repo cPAddons.repo cpanel-plugins.repo EA4.repo
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,870
    Likes Received:
    1,811
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The primary issue is that your system package manager (YUM) is unable to update successfully due to multiple installations of the same RPM. You will need to remove the duplicate RPMs while ensuring the dependencies are not removed (--nodeps flag). You may want to get assistance with this from your data center or hosting provider as removing the wrong RPM can result is OS-level errors. There are threads on this topic at:

    SOLVED - Can't upgrade from MySQL 5.6 to MariaDB 10.1
    The server's system package manager, 'YUM', failed. !!

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice