The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cant Upgrade Kernel With Yum Or Up2date

Discussion in 'General Discussion' started by bsasninja, Aug 9, 2006.

  1. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    I´m running centos 4.3 with kernel 2.6.9-22.0.1.ELsmp and I want to upgrade to 2.6.9-42 that is the latest and more stable.

    When I do yum update kernel it says that there is no package avaible for update. If I do "up2date kernel" I get an error and in /var/log/up2date says this:

    [Wed Aug 9 16:59:55 2006] up2date availablePackageList from network
    [Wed Aug 9 17:00:00 2006] up2date File "/usr/sbin/up2date", line 1265, in ?
    sys.exit(main() or 0)
    File "/usr/sbin/up2date", line 800, in main
    fullUpdate, dryRun=options.dry_run))
    File "/usr/sbin/up2date", line 1120, in batchRun
    batch.init()
    File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 65, in init
    self.__findPackagesToUpdate()
    File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 105, in __findPack agesToUpdate
    plist.run()
    File "/usr/share/rhn/up2date_client/packageList.py", line 132, in run
    progressCallback = self.progressCallback )
    File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 420, in obsolete sList
    progressCallback = progressCallback )
    File "/usr/share/rhn/up2date_client/rpcServer.py", line 316, in doCall
    ret = apply(method, args, kwargs)
    File "/usr/share/rhn/up2date_client/repoDirector.py", line 28, in getObsolete s
    return self.handlers[channel['type']].getObsoletes(channel, msgCallback, pro gressCallback)
    File "/usr/share/rhn/up2date_client/rpmSource.py", line 252, in getObsoletes
    msgCallback, progressCallback)
    File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 324, in ge tObsoletes
    baseFileName = "%s-%s-%s.%s.hdr" % (pkg[0], pkg[1], pkg[2], pkg[4])


    How can I update this correctly??

    Thanks
     
  2. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    more

    Even if i type yum check-update I get this:

    Setting up repositories
    update 100% |=========================| 951 B 00:00
    base 100% |=========================| 1.1 kB 00:00
    addons 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished

    why it doesnt upgrade or finds kernel 2.6.9-34 and leaves me with 2.6.9-22 ??? Like if there is no update :eek:
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You have to edit /etc/yum.conf and remove kernel* from the exclude= list and then run yum update. Afterwards, add kernel* back to the exclude= list
     
  4. bsasninja

    bsasninja Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    528
    Likes Received:
    0
    Trophy Points:
    16
    Great

    Now yes!
    The update detected the latest kernel-smp is 2.6.9-34.0.2.ELsmp

    The 2.6.9-42 is unofficial?

    Thank you Chirpy! :D
     
  5. WindyT

    WindyT Active Member

    Joined:
    Nov 30, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Edit: Fixed. Sorry to be a pain.
     
    #5 WindyT, Oct 3, 2006
    Last edited: Oct 3, 2006
Loading...

Share This Page