The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

can't use cpanel install exim~

Discussion in 'General Discussion' started by chris_ng, Oct 25, 2007.

  1. chris_ng

    chris_ng Member

    Joined:
    Mar 12, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    i just upgrdae cpanel to 11, seem all well, but when i try /scripts/exim4 or /scripts/eximup

    if got some error.

    Can't use an undefined value as a HASH reference at /scripts/cPScript/Update.pm line 62.

    who can told me how to fix this problem?
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Did you install PERL 5.8.8 first? I'm not sure if that is a part of the problem or not.

    If you haven't, read this: http://cpanel.net/products/cPanelandWHM/linux/cpanel11/releasenotes.pdf

    Mike
     
  3. chris_ng

    chris_ng Member

    Joined:
    Mar 12, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    yes, i type perl -v, my perl is 5.8.8 now. do i need reinstall cpanel?
    or try /script/upcp --force again?
     
  4. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Do this: /scripts/checkperlmodules

    See if it reports everything as okay. If you still have the problem, I would do a /scripts/upcp --force .

    Mike
     
  5. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator

    And then I would do a /scripts/eximup --force again if everything else seemed to go okay. And see if you still get the error.

    I've done some searching and haven't found any forums that mention that problem you are having, so if you still have the problem after this I would certainly recommend that you open a ticket with your Cpanel license provider.

    Mike
     
  6. chris_ng

    chris_ng Member

    Joined:
    Mar 12, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    i try /scripts/checkperlmodules
    ...
    perlmod--Install done
    Tested 96, 96 ok, 0 failed.
    seem like fine, but got same error when i run /scripts/exim4.

    after i try /scripts/upcp --force, but not work too, run /scripts/upcp --force will got same error :
    Can't use an undefined value as a HASH reference at /scripts/cPScript/Update.pm line 62.

    my exim is gone now.. :( have any way can fast to install exim back?
     
  7. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    You need to create the file /etc/cpupdate.conf containing the branch of cPanel you have installed. For example, if using Release, the contents of this file would be:

    Code:
    CPANEL=release
    
    Replace release with the branch of cPanel you are using.
     
Loading...

Share This Page