[case 104885] Many mailboxes can receive, but not send after upgrade to WHM 11.44.0 (build 14)

eurorocco

Well-Known Member
Jun 23, 2003
98
0
156
Hi!

This morning many email users reporting they can receive but not send after upgrade to WHM 11.44.0 (build 14) .

I thought it was the upgrade from Mysql 5.1 to Mysql 5.5, but one of the servers was on Mysql 5.5 already.

What operation within WHM or ssh can I do to fix this?

I also tried increasing authentication processes, but still... as if customers didn't have "my outgoing server requires authentication", but they do have that set.

Sorry if this post is misplaced. I'm in an emergency. Thanks a lot for your help!

ER
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
Hello :)

Could you let us know the output from /var/log/maillog and /var/log/exim_mainlog when this authentication failure occurs? Also, remember to always submit a bug report right away if you think it might be a flaw with the update to version 11.44:

Submit A Bug Report

You can then post the ticket number here so we can update this thread with the outcome.

Thank you.
 

eurorocco

Well-Known Member
Jun 23, 2003
98
0
156
Weird. Some customer had My Outgoing server requires authentication disabled... enabled it... and fixed his problem.

Some other customer reports he has this enabled and still cannot send. Let me do a round of customer checks over here.

Thanks for your help!
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,481
35
208
cPanel Access Level
DataCenter Provider
Weird. Some customer had My Outgoing server requires authentication disabled... enabled it... and fixed his problem.

Some other customer reports he has this enabled and still cannot send. Let me do a round of customer checks over here.

Thanks for your help!
We have opened up case 104885 to address this. cPanel 11.44 repairs missing entries in cpanel.config by examining the server configuration. If antirelayd was enabled but the entry was missing from cpanel.config, and it is unable to determine the state automaticlly it chooses the default which is disabled.

Disabling and re-enabling antirelayd in the service manager will ensure all the configuration is in sync and resolve the problem in the mean time.
 

eurorocco

Well-Known Member
Jun 23, 2003
98
0
156
Thanks a lot for your last reply too. Some customers were blocked by the firewall after sending without auth, so getting them unblocked was a first thing. Then asking them all to enable "my outgoing server requires authentication, sames as incoming".

As a measure I did upgrade server with force, then upgrade server software, upgrade system software. Then rebooted.

In earlier upgrades we had disabled antirelayd to give users some slack, but not anymore as spam is becoming more and more pervasive, and server reputation can go south.

Thanks again! Much appreciated!

ER
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
In earlier upgrades we had disabled antirelayd to give users some slack, but not anymore as spam is becoming more and more pervasive, and server reputation can go south.
Actually, Antirelayd should be disabled. This forces SMTP authentication instead of allowing IMAP/POP before SMTP authentication.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
A resolution for internal case number 104885 was included with cPanel version 11.44.0.17. Per our change log:

2014-06-21
Fixed case 104885: Set missing antirelayd in cpanel.config.


Feel free to force an update of cPanel if you do not have automatic updates enabled.

Thank you.
 
  • Like
Reactions: MaraBlue