[Case 128077] DNSOnly check_valid_server_hostname sends invalid alert

owine

Active Member
Jan 10, 2007
44
0
231
I have 3 DNSONLY VPSs around the world. I recently changed the hostnames by editing /etc/sysconfig/network, but all three sent me "Hostname Configuration Error" emails overnight with the message "WHM has detected a manual hostname change.". They linked to the WHM page to change the hostname, but this does not exist in DNSONLY. What is the proper method to change a hostname in DNSONLY and to clear this misconfiguration?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello :)

Please submit a bug report for this via:

Submit A Bug Report

That notification should be addressed for DNS-Only installations. In the meantime, you should be able to use the "hostname" command to correctly alter the hostname.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello :)

Yes, internal case number 128077 is open to address the issue where manual updates of the hostname on an 11.46+ DNSOnly server will trigger a hostname-change alert, and direct the user to update their hostname through WHM, which is not possible on a DNSOnly server. The "Change Hostname" option is going to be added to WHM on DNS-Only to address this issue. You can monitor our change log for the inclusion of the case number:

11.46 Change Log

Thank you.
 

JamesOakley

Well-Known Member
Apr 15, 2011
83
2
58
cPanel Access Level
Root Administrator
Just to add my 2p: I've hit the same issue. The correct, new, hostname is already showing in both /etc/sysconfig/network and with the hostname command. Yet I still get the error when I run /scripts/check_valid_server_hostname.

While I wait for the Change Hostname option to be added to WHM, what other commands might I run at the command line to do this manually?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
You can manually correct the hostname entry in /etc/wwwacct.conf until the resolution has been released.

Thank you.