[Case 132253] phpMyAdmin 4.2.9 requires MySQL 5.5 but cPanel can update to 11.46 with MySQL 5.1

Venomous21

Well-Known Member
Jun 28, 2012
85
0
6
cPanel Access Level
Root Administrator
Hello,

Thankfully, I only upgraded our test server from 11.44 to 11.46, however, when accessing phpmyadmin today as root, I get the message:

phpMyAdmin - Error
You should upgrade to mysql 5.5.0 or later.

I have been preparing our sites for this upgrade and testing them (and have run into issues, which is why the upgrade hasn't been done yet). Unfortunately, I am only allotted a set number of hours per week or the upgrade would have been done already.

Is there anyway to remove this error or downgrade back to 11.44? The ball was really dropped badly on this....I'm highly annoyed that I wasn't given a warning about this or prevented from upgrading to 11.46....I could quickly upgrade to mysql 5.5 on this server but I'm not done with testing and I'm not sure about all the sites it could break. I am thankful that I have auto-updating of cpanel off or this would have been a potential nightmare.

I can install an older version of phpmyadmin on a per site basis but don't want to have to do this for each server and am not sure how to have the old phpmyadmin version show up in each individual site account at port 2083 without installing each one manually. Annoyed and looking for advice. A lot of people still run mysql 5.1...yes I realize it's old but we should be warned before the upgrade.

If the easiest thing to do is force the upgrade to 5.5 and deal with broken sites, I may have to go that route. Thankfully, it's a test server but it's also a development server with client dev sites. Annoying to say the least.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello :)

Internal case number 132253 is open to address the issue where phpMyAdmin 4.2.9 requires MySQL 5.5 but cPanel can update to version 11.46 with MySQL 5.1. A different version of phpMyAdmin will be provided so that it works with MySQL 5.1, but there is currently no specific time frame for it's publication (it likely won't be very long due to the nature of this flaw). I will update this thread with more information as it becomes available.

Thank you.
 

Venomous21

Well-Known Member
Jun 28, 2012
85
0
6
cPanel Access Level
Root Administrator
Thank you for the quick update. I am in the process of installing phpmyadmin 4.1.x on a test site so our developers can access it but will wait for this update.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
You can monitor our change log for this case number:

11.46 Change Log

It's expected soon but there is no specific time frame available.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
how can i downgrade to v11.44.1 build21 ?
Once you upgrade to version 11.46, you will not be able to downgrade to a previous version. Progress has been made on internal case number 132253, and a resolution is expected next week.

Thank you.
 

dxisto

Registered
Nov 28, 2007
3
0
51
I've managed to fix this. You need to install the suPHP extension and restart apache, and voilà, it works.
In my environment I already have mod_suPHP compiled into apache, but still getting the infamous phpmyadmin error.
Can you post more details how you managed this?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Using suPHP is not considered a workaround. Per my previous post, progress has been made on internal case number 132253, and a resolution is expected next week.

Thank you.
 

zye

Well-Known Member
Dec 6, 2002
122
4
168
munin also stopped working with the update to WHM 11.46.0 (build 14) -. this sucks big time...


edit:
a restart of munin did solve it....
 
Last edited:

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
@TanVliet: Thanks for mentioning this. I've just manually upgraded the server to the new version.
 

kdean

Well-Known Member
Oct 19, 2012
377
65
78
Orlando, FL
cPanel Access Level
Root Administrator
11.46.0.17 seems to downgrade everyone to PHPMyAdmin 4.0.10.5. At least it did on my server and I was running 4.2.9 just fine with MySQL 5.6. So Now I'm using a version from a year ago.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
11.46.0.17 seems to downgrade everyone to PHPMyAdmin 4.0.10.5. At least it did on my server and I was running 4.2.9 just fine with MySQL 5.6. So Now I'm using a version from a year ago.
Per our Edge mailing list, here is our response:

phpMyAdmin 4.2 does not support MySQL older than 5.5. Since we
currently support 5.0, it simply isn't possible to use a newer version.

Note that despite the downgrade, this version actually fixes some
security bugs as well as one or two other bugs we've seen.

brian m. carlson
Release Marshal / cPanel, Inc.
Thank you.
 

kdean

Well-Known Member
Oct 19, 2012
377
65
78
Orlando, FL
cPanel Access Level
Root Administrator
I just took the discussion earlier in this thread that MySQL 5.5 and later would see phpMyAdmin 4.2 installed and earlier than 5.5 would see older phpMyAdmin versions installed so people up-to-date on MySQL would not be penalized by a lowest common denominator situation. Can the install process not handle and if then else for phpMyAdmin?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
I just took the discussion earlier in this thread that MySQL 5.5 and later would see phpMyAdmin 4.2 installed and earlier than 5.5 would see older phpMyAdmin versions installed so people up-to-date on MySQL would not be penalized by a lowest common denominator situation. Can the install process not handle and if then else for phpMyAdmin?
It's not planned at this time. You can open a feature request for this via:

Submit A Feature Request

Thank you.
 

themew

Member
Nov 19, 2014
6
0
1
cPanel Access Level
Website Owner
Since cPanel phpMyAdmin was downgraded to 4.0.10.5. I wanted to be sure cPanel admins knew there was a vulnerability in that version.

A vulnerability present in in phpMyAdmin 4.0.x before 4.0.10.7, 4.1. x
before 4.1.14.8, and 4.2.x before 4.2.13.1 allows remote attackers to
cause a denial of service (resource consumption) via a long password.
CVE-2014-9218 was assigned

Link > phpMyAdmin 4.0.x, 4.1.x, 4.2.x Denial of Service - CXSecurity.com
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Since cPanel phpMyAdmin was downgraded to 4.0.10.5. I wanted to be sure cPanel admins knew there was a vulnerability in that version.
Hello :)

Yes, internal case number 144589 was opened to ensure phpMyAdmin is updated to 4.0.10.7. We monitor security reports and vendor releases. There is currently no specific time frame available on when this version will be included with cPanel.

Thank you.