PCZero

Well-Known Member
Dec 13, 2003
718
85
178
Earth
I am attmpting to set up WebDisk for several clients. On all every device for every client that I have attempted to do this I get several errors. The majority of cases are installs on Win7 boxes.

There is the warning "Your account has not yet been setup for Digest Authentication" present and when I click the "Enable Digest Authentication" link an error is returned...

"Digest Authentication could not be enabled because the supplied password was not correct. Please try again."

If I simply click the "Access Web Disk" button I get the page that has several combo boxes for connect instructions. The first step for Win7 is to download a file to the desktop. When I click that link an error is returned...

"An invalid domain name was passed."

There is a message "Clear Text/Not Encrypted Connection Not Available" as well.

Please advise how I can get this working.
 
Last edited:

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
Thank you for bringing this to our attention. We're working on a fix. As noted in the adjusted case title the fix is currently being tracked by case 180053.
 

PCZero

Well-Known Member
Dec 13, 2003
718
85
178
Earth
Thanks for the update Kenneth. I noticed the title change and was thinking that was what was up. If you or the development team have any questions as to my particular setup (if it appears that this may be relevant to a fix) please feel free to email me.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
Thanks for the update Kenneth. I noticed the title change and was thinking that was what was up. If you or the development team have any questions as to my particular setup (if it appears that this may be relevant to a fix) please feel free to email me.
Thank you for the offer.
 

PCZero

Well-Known Member
Dec 13, 2003
718
85
178
Earth
Kenneth has this entered the pipeline yet? Specifically have programmers started address it at all? I have several clients waiting for this fix so they can set up web disk.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
Kenneth has this entered the pipeline yet? Specifically have programmers started address it at all? I have several clients waiting for this fix so they can set up web disk.
Yes, it is being worked on. All the web disk script configuration generators broke. We are working on getting all of them fixed and published.
 
  • Like
Reactions: PCZero

PCZero

Well-Known Member
Dec 13, 2003
718
85
178
Earth
Thanks for the very prompt reply Kevin. I am relieved that this is a issue on y'all's end and not something specific to my configuration. If you do happen to get word of a pending release please keep me in the loop. Thanks again.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
Thanks for the very prompt reply Kevin. I am relieved that this is a issue on y'all's end and not something specific to my configuration. If you do happen to get word of a pending release please keep me in the loop. Thanks again.
I haven't been called Kevin in a long time ;)

The problem with the configuration changes will be addressed in 11.48.3. We are planning on releasing that to CURRENT early next week.
 
  • Like
Reactions: PCZero

PCZero

Well-Known Member
Dec 13, 2003
718
85
178
Earth
1) I am severely lysdexic (seriously I am).

2) Thank you for the update and for the extremely quick response in getting this addressed.
 

PCZero

Well-Known Member
Dec 13, 2003
718
85
178
Earth
Hey guys thanks for the fix. Unfortunately it only half way fixes the issue. I see that you now get prompted for the password when enabling digest in WHM but it still fails in the clients cpanel interface!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hey guys thanks for the fix. Unfortunately it only half way fixes the issue. I see that you now get prompted for the password when enabling digest in WHM but it still fails in the clients cpanel interface!
Hello,

I've not been able to reproduce an error message when enabling digest authentication for Web Disk when logged into cPanel with the cPanel account username and account password. Could you let us know the exact steps we should take to reproduce the issue? For instance, when you state that it fails, what specific error message do you receive?

Thank you.
 

PCZero

Well-Known Member
Dec 13, 2003
718
85
178
Earth
Michel i will follow up in a week or so. I leave for a 7-day cruise of the Caribbean in about 3 hours! Ths can wait. :)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Also, are you using the X3 theme or Paper Lantern?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

Thank you.