[Case 42592] cPanel Mailing Lists Modify links to wrong URL?

jimhermann

Well-Known Member
Jan 20, 2008
71
2
58
Crew,

Does this happen on your cPanel Installation?

Click on Mailing List
Click on Modify for any mailing list with more than 25 members

URL is http://servername.tld/mailman/admin/listname_domainname.tld
[It should be http://domainname.tld/mailman/admin/listname_domainname.tld]

Enter password

Click on Membership Management
Click on any letter of the alphabet

URL is http://domainname.tld/mailman/admin/listname_domainname.tld/members?letter=a

Web page is Mailman Administrator Authentication and the password must be entered again.

This also happens with the link for "Click here to hide the legend for this table."

Also, the "Overview of domainname.tld mailing lists" link is wrong for all web pages.

Thanks.

Jim
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello Jim,

I am seeing this behavior but only when I log in using https://servername.tld:2083 for the mailing list. We have an internal case (42592) already opened about the Modify link in cPanel > Mailing Lists area using the url that you used for logging into cPanel. This mean that if you use servername.tld to log into cPanel, that the modify link will use that same name for the mailing list url.

The way around this issue would be to use the domain name to log into cPanel (https://domain.com/cpanel or https://domain.com:2083/) instead.

Also, if you do switch to WHM > Tweak Settings for this to On:

Prefix “mail.” onto Mailman URLs [?]
Add the mail. prefix for mailman URLs (ie http://mail.domain.com/mailman)
It will force mail.domain.com onto the mailing list url for cPanel > Mailing Lists > Modify link.

I will update the internal case I had opened to indicate this additional information that the password prompt keeps occurring when you try to switch between letters in the Mailman Mailing List admin's Membership Management section.