The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Case 46364] Problem with "Require SSL for all remote logins to cPanel ..."

Discussion in 'General Discussion' started by FreedomBI, Jan 3, 2010.

  1. FreedomBI

    FreedomBI Well-Known Member

    Joined:
    Jul 7, 2008
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    I have come across a problem with the security setting "Require SSL for all remote logins to cPanel, WHM and Webmail. This setting is recommended." With webmail, it always tries to redirect to port 2096. Eg, if you have example.com and go to https://webmail.example.com, it will try to redirect you to https://webmail.example.com:2096 even though it's already using SSL. This results in users behind a firewall being unable to access webmail. Turning off this option restores normal functionality.

    I have only tried this with webmail. I haven't tried cpanel or whm.
     
  2. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    If you wish to disable this feature then you can disable it from WHM -> Tweak settings -> Redirection -> Unselect the option "Always redirect users to the ssl/tls ports when visiting /cpanel, /webmail, etc."
     
  3. FreedomBI

    FreedomBI Well-Known Member

    Joined:
    Jul 7, 2008
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    "Always redirect users to the ssl/tls ports when visiting /cpanel, /webmail, etc." has no effect on this. With this disabled and "Require SSL for all remote logins..." enabled, the problem still occurs. It does not occur with "Always redirect" on and "Require SSL" off.
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I believe the intended behavior is that of redirecting to the SSL port; however, I see the noted scenario is when using an SSL virtual host in Apache with the proxy sub-domains feature. Please consider submitting a support request so we may inspect and verify the specific circumstances and assist with investigating the issue; when available, please PM me the ticket ID number so I may follow-up internally.
     
  5. tomi1122

    tomi1122 Member

    Joined:
    Aug 31, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Was there ever a resolution for this problem?

    Tom
     
  6. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    To the best of my knowledge the difficulty that was initially described should be fully alleviated. Upon testing, using cPanel version 11.25.1-EDGE_47010 and Apache version 2.2.15, I was unable to reproduce a scenario where SSL access to the webmail proxy sub-domain triggered a visible redirect to SSL port 2096 for webmail. I tested with "Always redirect to SSL" both enabled (On) and disabled (Off), each time with "Require SSL" enabled (On).

    Are you currently seeing behavior different than what I've described above or are you experiencing any difficulty accessing services via the applicable proxy sub-domain?
     
  7. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Friendly Moderator Note

    Before posting I did not yet see the separate thread that you started; however, after reviewing the information posted there I believe it may be a different issue at the root of the symptoms. Please refer to my reply posted within your new thread. To prevent confusion with the older inquiry please continue applicable discussion in the newer thread that is dedicated to your unique circumstances. Thank you for your understanding. :)
     
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,471
    Likes Received:
    199
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Important cPanel/WHM Version Number Designation Change

    Please Note: Important cPanel/WHM Version Number Designation Change

    As of July 28, 2010 the cPanel/WHM version number designations have been officially changed.

    Version 11.25.1 is now designated 11.28 and version 11.25.2 is now designated 11.30.

    These new changes were explained in some detail recently at the July 2010 - Quarterly Road map - Webinar direct from cPanel's PodCast Studio in Houston, Texas with speakers David Grega and Mario Rodriguez.

    An official press release about these changes is forthcoming and can be accessed at this link as soon as it's made available to the Forum Team:
    Important cPanel/WHM Version Number Designation Change (To be updated)

    This post serves to update users who are subscribed to threads (where this message is posted) looking forward to upcoming enhancements in future versions of cPanel.
     
  9. equens

    equens Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    270
    Likes Received:
    0
    Trophy Points:
    16
    re: [Case 46364] Problem with "Require SSL for all remote logins to cPanel ..."

    Hello FreedomBI, how do you solved this problem? I can´t turn "Require SSL" On, because http://webmail.example.com shows a text with a link to redirect the user to https://webmail.example.com:2096.
     
  10. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    re: [Case 46364] Problem with "Require SSL for all remote logins to cPanel ..."

    The only method to avoid this, at this time, is to disable Require SSL in Main >> Server Configuration >> Tweak Settings. This setting is under the Security tab.

    A request to change this behavior and cause proxy subdomains to work through the SSL ports has already been filed with our developers. There is no estimated time for when this will be changed, but it is being considered for a future version. The case number is 46364, and the case number will be mentioned in the changelog when a change affecting this behavior is published in a public build.
     
  11. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Case 46364 was resolved in the early builds of 11.30. To see if 11.30 has reached your update tier yet, visit Downloads - cPanel Inc.
     
  12. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Re: [Case 46364] Problem with "Require SSL for all remote logins to cPanel

    David,

    can you please 46364, I don't see it on the changelog website.
     
  13. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Re: [Case 46364] Problem with "Require SSL for all remote logins to cPanel

    On the 11.30 changelog, you will see this case listed for version 11.29.0.11 (a pre-production version of 11.30).
     
  14. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    Re: [Case 46364] Problem with "Require SSL for all remote logins to cPanel

    Im on WHM 11.30.3 (build 5) and im having this problem yet. I have:

    Always redirect to SSL: On
    Non-SSL redirect destination: hostname
    SSL redirect destination: SSL Certificate Name

    It continue showing the "Log in using SSL" link when i go to webmail.dom.com. When i click on it it redirecting to the port 2096 (for webmail for example).

    I did tes in one domain running /scripts/proxydomains for that domain specifically, nothing has changed.

    Any idea? I have the same problem in all the servers i have.

    Thanx in advance!
     
Loading...

Share This Page