The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Case 50495] Error Saving after apparent upgrade

Discussion in 'General Discussion' started by omnidesigner, Jun 1, 2011.

Thread Status:
Not open for further replies.
  1. omnidesigner

    omnidesigner Registered

    Joined:
    Jun 1, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have been dealing with cPanel now for a few weeks. Starting today, after making simple changes to code, I am unable to save anything. I keep getting a error code

    "Error encoding as ISO-8859-1: /usr/bin/iconv: illegal input sequence at position 7623"

    I have not seen anything in the forums here yet and it only started today. Some help identifying this error and now to fix it would be very helpful.

    NOTE: this appears to have something to do with google, as I have google anaylitics coding here, but that shouldn't be causing a error of anykind!
     
  2. kampret

    kampret Member

    Joined:
    Jun 21, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I have experience the same issue after upgrade to 11.30 (build 23 and/or 25).
    My temporary solution now is just change meta charset from ISO-8859-1 to utf-8.
    I hope Cpanel will soon release next build to fix this.
     
  3. ipns

    ipns Member

    Joined:
    May 9, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    How do you change the meta charset from ISO-8859-1 to utf-8?
     
  4. kampret

    kampret Member

    Joined:
    Jun 21, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I change that directly through the html file source code which need to edit.
    Edit your file from local pc or from "Edit" menu only, from Cpanel File Manager.
    Go find <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> and change charset value to utf-8.
     
    #4 kampret, Jun 8, 2011
    Last edited: Jun 8, 2011
  5. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This sounds like a bug we are currently tracking down related to the HTML Editor. Apparently if certain HTML entities exist in your source file, such as &copy; the HTML Editor will transform this to the actual utf-8 character. If the HTML Editor then attempts to save the file as ISO-8859-1 (sometimes known as latin-1), this results in the error message reported in the first post.

    One solution to this, and really the majority of character encoding issues, is to use only utf-8 when creating and saving files.

    We are currently examining potential solutions to this. For version 11.30.0 the case # is 50495.
     
  6. pengtatt

    pengtatt Registered

    Joined:
    Jun 13, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    There is no "meta http-equiv" or iso-8859-1 in my html file but I still having the same problem.
    I tried to use the code-editor in c-panel to convert my html file to utf-8. However, whenever I use the html editor to edit the same file and save the changes, the problem still persists.

    Any solution to this? Many thanks :)
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    The case has been corrected in 11.30.0.31, so once EDGE reaches that version, you could always update to EDGE for the time being for the resolution if trying to save the file in utf-8 is not working as a solution. Right now, EDGE is on 11.30.0.30 version, but you can check Downloads - cPanel Inc. to see when EDGE has gone to .31
     
  8. prdad007

    prdad007 Registered

    Joined:
    Jun 13, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1

    Iam having simiar problem : Error encoding as ISO-8859-1: /usr/bin/iconv: illegal input sequence at position 7527 - as I try to save a file in cPanel on my MAC. This is the beginning of the page:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">

    There is no 8859-1 on the page. I need to modify/update this page ASAP.

    Help please.

    -Steve
     
  9. kampret

    kampret Member

    Joined:
    Jun 21, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    just my thought, you may try to manually add the line of <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> by your self.
    put that tag line between <head> and </head> tag on any html page which need to edit.

    hope this helps.
     
  10. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    All versions of 11.30 should now have the fix for this issue. If you are still having issues, please ensure you haven't disabled the file encoding check in File Manager. You can always revert to the old settings using cPanel > reset all interface settings option (it is normally at the bottom of the Main page).

    Additionally, I did want to mention that FTP clients can be used to download and edit pages if you have any issues in File Manager as a remedy until a case like this has been fixed. FTP clients such as Filezilla are free to use and it is always a great idea to have local copies on your computer for files you are storing on your web account anyway. You can download Filezilla at this location:

    FileZilla - Client Download
     
  11. prdad007

    prdad007 Registered

    Joined:
    Jun 13, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Good idea. I had considered the same. And now that I have tried it, i continue to get the same error. Argh. None of my other pages have this problem. Help still requested & required. Thanks.:(
     
  12. BrynP

    BrynP Registered

    Joined:
    Jun 22, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I am in the same boat as this person, changing it to utf-8 through the cPanel interface worked but now after I manually entered <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> on some different files, it is still trying to save as ISO-8859-1 not utf-8, but when I open it in Code or Text Editor it shows the file encoding as utf-8. Arrg.
     
  13. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you cannot get File Manager to work for this utility, please open up a ticket if the proposed resolutions do not work for you. You can submit a ticket using WHM > Support Center > Contact cPanel or using the link in my signature.
     
  14. jave200372

    jave200372 Registered

    Joined:
    Jan 1, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    In the File Manager, select the "Settings" in the top left-hand corner of the window. Disable the "Character Encoding Verification Dialogs". Now go to HTML edit you file. You should be able to select "utf-8" as the character set for your html file, edit then save your changes. Worked for me. You can then change the settings back to normal and proceed to edit the same file again. Hope this helps.

    Jave.
     
  15. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    I get this error when using the Code Editor (i.e. not the HTML editor) to edit PHP files as well.
     
  16. lbeachmike

    lbeachmike Well-Known Member

    Joined:
    Dec 27, 2001
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Beach, NY
    cPanel Access Level:
    Root Administrator
    I have a client with this issue. How do I ensure that the file encoding check is not disabled without reverting all settings as you suggest?

    Thanks.

    Mike
     
  17. lbeachmike

    lbeachmike Well-Known Member

    Joined:
    Dec 27, 2001
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Beach, NY
    cPanel Access Level:
    Root Administrator
    Okay - found this at File Manager -> Settings

    Turned it off and no difference. Still get same error message on trying to save.

    I am unclear on how this is considered to be fixed in all .30 releases if it still does not actually work without error.

    Can you please clarify?

    Thanks.

    Mike
     
  18. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hi,

    Upon disabling the encoding check, you will receive this prompt at the end after saving or closing the file that was edited in File Manager:

    The 'Settings' link is at the top left of File Manager (Ctrl+F for it if unable to find it) and it simply has the option to turn on or off the encoding check.

    Thanks!
     
  19. lbeachmike

    lbeachmike Well-Known Member

    Joined:
    Dec 27, 2001
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Beach, NY
    cPanel Access Level:
    Root Administrator
    Wow - you're fast. Our responses overlapped and I continue to have the issue - I've opened a support ticket.

    Thanks.

    Mike
     
  20. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Can everyone experiencing this problem (not just sysadmins) please submit a ticket or bug report to us about this if you haven't done so already? This will help us:

    - Gather more information about the situation allowing us to implement a better fix
    - Expedite a resolution (more reports = higher priority = faster fix)
    - Email you when this is fixed

    You can submit a bug report by clicking the Bugs link at the top of this page or visiting http://go.cPanel.net/bugs - and if you have any problems using that system, you can just drop me an email to sales@cpanel.net and I'll route you into our bug reporting system from our end.

    We'd love to get more reports about this so we can have a more complete picture of what's going on. I'm going to close this thread now, so if you have any further commentary, please either file a report or follow up with the report you have filed already.

    Thanks!
     
Loading...
Thread Status:
Not open for further replies.

Share This Page