Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

[Case 52321] Bug - Cant change ServerLimit whit MPM_Event ( Lower than Max Request Workers )

Discussion in 'EasyApache' started by Skamasle, Nov 7, 2013.

  1. Skamasle

    Skamasle Member

    Joined:
    Mar 18, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    HI first of all sorry for my bad english.

    I use apache 2.4 and mpm_event.

    I try set a ServerLimit value to 40 and Max Request Workers to 100, and get this error

    So is the same error when try set a highest value of serverlimit than Request Workers using prefork.

    But that error using prefork is normal, I understand it.

    The problem here is if I set default cpanel value to apache using mpm_event I get overload, so

    Code:
    Serverlimit 256
    Max Request Workers 150
    Using event thats mean than apache can start 256 servers and each server can handle 150 request so 256 * 150 = 34800 request

    I dont know if I dont understand how working mpm_Event ( but I think I undestand it )

    Is like nginx workers
    Code:
    [B]worker_processes 1[/B]; = ServerLimit
    [B]worker_connections 600[/B]; = Max Request Workers
    Is something like that.

    Now I say this because I have some servers whit 7k online people on analytics but are 150 to 400 req/s and apache overload the server until than I change serverlimit value

    So if I do something like this:
    Code:
    Serverlimit 256
    Max Request Workers 150
    I get a lot of apache process ( 256 ) And load average go up until 150

    But if I manually change that from ssh to
    Code:
    ServerLimit 40
    Max Request Workers 400
    I get only 40 I get 40 apache process, and serverload of 5 and site response is in only on 1s.

    So the point is than I cant set a ServerLimit value lower than Max Request Workers I untherstand it if I use prefork but whit event I have alot of problems.

    The same problem I get before whit worker, whit worker serverlimit value is very low so works similar to event, here the default mpm_worker config from apache's site:

    Code:
    ServerLimit         16
    StartServers         2
    MaxRequestWorkers  150
    MinSpareThreads     25
    MaxSpareThreads     75
    ThreadsPerChild     25
    So if you try put it vía WHM using worker you get error like this:


    And the last problem here is than I set Max Request Workers and cpanel say cant change maxclients


    I test this on 5 servers and get same error.

    I hope you understandme, I try to report a bug ( if is bug ) but dont see any bugtracker or bug report category.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 Skamasle, Nov 7, 2013
    Last edited: Nov 7, 2013
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,323
    Likes Received:
    1,851
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Please submit bug reports via:

    Submit A Bug Report

    You can post the ticket number you are assigned to this thread and we can provide updates on the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Skamasle

    Skamasle Member

    Joined:
    Mar 18, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    HI thanks for reply, I looking for that option :D

    The number is: 4390551
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Skamasle

    Skamasle Member

    Joined:
    Mar 18, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    The temporaly solution is edit the

    Then rebuild httpd.conf

    Case # 52321

    Hope can fix that shortly.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,323
    Likes Received:
    1,851
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Yes, the workaround is to modify the "maxclients" value in the "/var/cpanel/conf/apache/local" file. Here is an example of the output of this value after modifying the file:

    Code:
    # grep maxclients /var/cpanel/conf/apache/local
      "maxclients":
          "maxclients": 400
    Ensure the Apache configuration file is rebuilt after making the change:

    Code:
    /scripts/rebuildhttpdconf
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice