The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Case 55043] /scripts/perlinstaller Image::Magick show error ?

Discussion in 'Security' started by minosjl, Dec 6, 2011.

  1. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi ,

    I have tried to install the perl module Image::Magick using the below command and getting error.Please help me on this.

    /scripts/perlinstaller Image::Magick

    --------

    CPAN.pm: Building J/JC/JCRISTY/PerlMagick-6.72.tar.gz

    Checking if your kit is complete...
    Looks good
    Writing Makefile for Image::Magick
    Writing MYMETA.yml and MYMETA.json
    CPAN: Module::CoreList loaded ok (v2.45)
    cp Magick.pm blib/lib/Image/Magick.pm
    AutoSplitting blib/lib/Image/Magick.pm (blib/lib/auto/Image/Magick)
    /usr/bin/perl /usr/lib/perl5/5.8.8/ExtUtils/xsubpp -typemap /usr/lib/perl5/5.8.8/ExtUtils/typemap -typemap typemap Magick.xs > Magick.xsc && mv Magick.xsc Magick.c
    cc -c -I/usr/local/include/ImageMagick -I../ -I.. -I"/usr/include/ImageMagick" -I/usr/local/include/ImageMagick -fopenmp -g -O2 -Wall -pthread -fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -DVERSION=\"6.72\" -DXS_VERSION=\"6.72\" -fpic "-I/usr/lib/perl5/5.8.8/i686-linux/CORE" -D_LARGE_FILES=1 -DHAVE_CONFIG_H Magick.c
    cc1: error: unrecognized command line option "-fopenmp"
    gmake: *** [Magick.o] Error 1
    JCRISTY/PerlMagick-6.72.tar.gz
    /usr/bin/gmake -- NOT OK

    CPAN: YAML loaded ok (v0.77)
    Running make install
    Make had returned bad status, install seems impossible
    perlmod--Install done
    ----------------
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    We have case 55043 opened about this issue where gcc is an older version than is supported by ImageMagick installation. The steps noted in the case to work around the issue were the following:

    Code:
    yum install gcc4
    cd /usr/bin
    mv gcc gcc.bak
    ln -s gcc4 gcc
    /scripts/perlinstaller Image::Magick
    rm gcc
    mv gcc.bak gcc
    It appears to only impact CentOS / RHEL 4 systems.
     
  3. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    hi,

    Thank you for the support , i have installed the perl module Image::Magick.But failed to install the ImageMagick getting the following error

    -------

    cp Magick.pm blib/lib/Image/Magick.pm
    AutoSplitting blib/lib/Image/Magick.pm (blib/lib/auto/Image/Magick)
    /usr/bin/perl /usr/lib/perl5/5.8.8/ExtUtils/xsubpp -typemap /usr/lib/perl5/5.8.8/ExtUtils/typemap Magick.xs > Magick.xsc && mv Magick.xsc Magick.c
    Could not find a typemap for C type 'Image::Magick' in Magick.xs, line 2270
    make[2]: *** [Magick.c] Error 1
    ----------
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Is your system CentOS 4 or RHEL 4? Can you please confirm the details on it:

    Code:
    cat /etc/redhat-release
     
  5. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    hi,

    CentOS release 4.9 (Final)
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Would you be able to open up a ticket at WHM > Support Center > Contact cPanel or using the link in my signature? Please post the ticket number here upon opening it. We would want to check what else might be going wrong on this CentOS 4 version for installing the perl module. Thanks!
     
  7. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    hi,

    Thank you for your quick response in this issue and pointing out the root cause of the issue.I have managed to fix this error by updating the kernel.
     
Loading...

Share This Page