[Case 62804] Small bug when upgrading to PHP 5.4.17

vlee

Well-Known Member
Oct 13, 2005
368
25
178
Spokane, Washington
cPanel Access Level
Root Administrator
I found a small bug when you use Easy Apache to upgrade PHP to PHP 5.4.17 from PHP 5.3.x.

Everything seems to work fine until like a few hours after the upgrade was done.

Then I noticed that disk space was being eating up faster. I then looked into the matter and found in almost every website in the /home had an error_log file that gets big fast.

So in this error_log file revealed the problem.

Since these 2 PHP extensions below does not work and/or are not needed and/or moved in PHP 5.4.17 for some reason these 2 extensions below are not removed from the php.ini file.

suhosin.so
sqlite.so

So you can comment them out or remove them in the php.ini file and restart Apache. I removed them myself.

To be on the safe side and verify that things will still work, I recompiled again using Easy Apache.

Now seems to be no more error_logs being generated now in the /home partition.

Something for cPanel to look at.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello :)

There is an internal case open to ensure the Suhosin module is actively disabled when PHP 5.4 is selected. For reference, the case number is 62804. However, I see no active reports or complaints about PHP 5.4 with SQLite. Could you open a ticket for the SQLite issue so we can reproduce the issue and open an internal case if necessary?

Submit A Ticket

You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
To update, we were unable to reproduce the issue with SQLite on a test server. It's possible this was due to a custom modification where the path to sqlite.so was hard-coded to the wrong location.

Thank you.
 

vlee

Well-Known Member
Oct 13, 2005
368
25
178
Spokane, Washington
cPanel Access Level
Root Administrator
To update, we were unable to reproduce the issue with SQLite on a test server. It's possible this was due to a custom modification where the path to sqlite.so was hard-coded to the wrong location.

Thank you.
There was no customization.

Maybe mine was an odd ball server then. But it would not hurt to make a notation of this issue if someone else runs into the same issue.