[case 64024 - pureftpd config not rebuilt after rpm update] 11.36.0.11 - A bit of a dog?

Karl

Well-Known Member
PartnerNOC
Aug 10, 2001
86
1
308
I don't know about anyone else, but for the first time in quite a long time we've seen a number of issues caused by the few machines updated to 11.36.0.11 overnight:

1) One machine enabled the auto-conf email settings, and it re-wrote some DNS zones so all A records (except the autoconf ones) pointed to another server in the cluster - The userdata file was fine, still had the correct IP.

2) Two other servers had their pure-ftpd.conf half re-written, even though the TLS settings were in the /var/cpanel/conf/pureftpd/main file they were in pure-ftpd.conf as the commented out defaults. It also missed the passive ports config out as well. Going in to WHM and saving the config (no changes) re-wrote pure-ftpd.conf properly.

3) A colo customers server started seg-faulting on half their sites. We had to recompile Apache to get this to stop.

These issues all occurred after they were updated last night, on servers that were previously working flawlessly.

I'm posting these here in the hope that if someone else has similar problems they'll know what is going on.

Has anyone seen any other issues we should be watching out for?

Unfortunately 11.36 looks a bit of a dog so far and not up to usual cPanel standards - it's been several years since we had any issues caused by updates.
 

ES - George

Well-Known Member
PartnerNOC
Jun 12, 2011
179
25
68
UK
cPanel Access Level
DataCenter Provider
Twitter
I noticed point 2 on a customer machine earlier. Someone complained about FTP not working (since CSF is installed and we had to make the passive port changes) and we had previously fixed this, but the pure-ftpd configuration file was overwritten.

Not seen any other problems yet.
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
If you have a custom pure-ftpd rpm installed or have pure-ftpd updates disabled the update will likely fail. You can force cPanel to manage the rpm by running the following:

Code:
/usr/local/cpanel/scripts/update_local_rpm_versions --del target_settings.pure-ftpd && /usr/local/cpanel/scripts/check_cpanel_rpms --fix
 

oadem

Registered
Mar 12, 2013
1
0
1
cPanel Access Level
DataCenter Provider
If you have a custom pure-ftpd rpm installed or have pure-ftpd updates disabled the update will likely fail. You can force cPanel to manage the rpm by running the following:

Code:
/usr/local/cpanel/scripts/update_local_rpm_versions --del target_settings.pure-ftpd && /usr/local/cpanel/scripts/check_cpanel_rpms --fix

I think you're misunderstanding the problem. Here's what happened to us: The auto-update installed 11.36 last night. The /etc/pure-ftpd.conf was overwritten with a default one from the RPM. Our cPanel customizations were temporarily overwritten by this. I had to click WHM -> Service Configuration -> FTP Server Configuration, (not changing any fields) and press Save, to correctly save the settings we had chosen back to /etc/pure-ftpd.conf. I expect such upgrades to maintain our changes (which cPanel clearly knew about) and save them automatically. I expect this is bug will be fixed in a future release.

We did not use any custom RPM, nor did we disable pure-ftpd updates.

EDIT: I knew the config was default because RPM had even made a /etc/pure-ftpd.conf.rpmsave containing the correct values, while the default one had most fields commented out. We noticed this because TLS behavior changed. I assume this bug occurs for anyone migrating from the non-cPanel managed pure-ftpd RPM, to the cPanel-managed RPM (e.g. probably everyone).
 
Last edited:

vikins

Well-Known Member
Oct 3, 2006
120
1
168
oadem is correct about the pure-ftp config file issue. This happened to one of our boxes as well. Resolved it using the same method.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
308
cPanel Access Level
Root Administrator
I think you're misunderstanding the problem. Here's what happened to us: The auto-update installed 11.36 last night. The /etc/pure-ftpd.conf was overwritten with a default one from the RPM. Our cPanel customizations were temporarily overwritten by this. I had to click WHM -> Service Configuration -> FTP Server Configuration, (not changing any fields) and press Save, to correctly save the settings we had chosen back to /etc/pure-ftpd.conf. I expect such upgrades to maintain our changes (which cPanel clearly knew about) and save them automatically. I expect this is bug will be fixed in a future release.

We did not use any custom RPM, nor did we disable pure-ftpd updates.

EDIT: I knew the config was default because RPM had even made a /etc/pure-ftpd.conf.rpmsave containing the correct values, while the default one had most fields commented out. We noticed this because TLS behavior changed. I assume this bug occurs for anyone migrating from the non-cPanel managed pure-ftpd RPM, to the cPanel-managed RPM (e.g. probably everyone).
Thank you for the added information. We are working on a fix for this issue (both as an autofixer and in a release).
 

Silver_2000

Well-Known Member
Mar 31, 2002
337
1
318
Looks like Ive been impacted as well

Restarting Pure-FTPD

Ftp Server...

Waiting for ftpserver to restart..........finished.

pure-ftpd (/usr/sbin/pure-ftpd -O clf:/var/log/xferlog --daemonize -A -c500 -B -C500 -D -E -fftp -H -I15 -lextauth:/var/run/ftpd.sock -L2000:8 -m4 -p30000:35000 -s -U133:022 -u100 -i -Oxferlog:/usr/local/apache/domlogs/ftpxferlog -o -k99 -Z -Y1 -JHIGH:MEDIUM:+TLSv1:!SSLv2:+SSLv3) running as root with PID 19952 (process table check method)
pure-authd (/usr/sbin/pure-authd -s /var/run/ftpd.sock -r /usr/local/cpanel/bin/pureauth) running as root with PID 19954 (pidfile check method)

ftpserver has failed, please contact the sysadmin.

...Done
Im running CSF as well
Ive tried resaving the config - didnt help
What else should I check ?
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
Looks like Ive been impacted as well


Im running CSF as well
Ive tried resaving the config - didnt help
What else should I check ?
Do you have cxs installed as well? It looks like you are starting with the -o flag. Pure-ftpd won't start listening until the upload socket is connected.

You might comment out CallUploadScript yes in /etc/pure-ftpd.conf and restart pure-ftpd if whatever is susposed to attach to /var/run/pure-ftpd.upload.pipe isn't working.
 

Silver_2000

Well-Known Member
Mar 31, 2002
337
1
318
yes also running csx -
This has to be related to the Cpanel upgrade

the FTP config hasnt changed in years
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
There is definitely a compatibility problem with cxs and 11.36 + pure-ftpd. I don't know exactly how cxs works so I'll see if get in touch with ConfigServer to get this worked out. In the mean time if you are having trouble getting pure-ftpd working you'll just need to comment out the CallUploadScript script line in /etc/pure-ftpd.conf and restart it.
 

Silver_2000

Well-Known Member
Mar 31, 2002
337
1
318
THats got it

One note for the next guy that has this issue - set the server back to pure ftp FIRST then edit the file
then restart the service
 

morphey

Member
PartnerNOC
Mar 13, 2006
6
0
151
Italy
cPanel Access Level
DataCenter Provider
Twitter
Hi,

I have the exact same problem.
After the updates (and restart) the server stops working pureftp "CallUploadScript" to On

You can have a solution to the problem?

The installed version is: pure-ftpd-1.0.36-5.cp1136
 

Robert Vining

Registered
Sep 24, 2007
1
0
51
Hate to bring up a 2 week old thread, but the Pure-FTP issued showed up for me after last nights update to 11.36.0 (Build 20) and after Commenting out etc/pure-ftpd.conf

CallUploadScript yes

FTP restarted just fine.