[case 64049] Overnight Update Failed MySQL conflicts with mysql-5.0.77-4.el5_4.2.i386

mtbwacko

Well-Known Member
Nov 30, 2004
56
0
156
My automatic update for one of my servers failed last night for the first time in years. Does anyone know how to remedy this? Thanks.

[20130128.230346] Testing RPM transaction
[20130128.230348] error: Failed dependencies:
[20130128.230348] MySQL conflicts with mysql-5.0.77-4.el5_4.2.i386
[20130128.230348] W Exit Code: 254
[20130128.230348] ***** FATAL: Test install failed: error: Failed dependencies:
[20130128.230348] MySQL conflicts with mysql-5.0.77-4.el5_4.2.i386
[20130128.230348] The Administrator will be notified to review this output when this script completes
[20130128.230348] E Error testing if the RPMs will install: Died at /usr/local/cpanel/scripts/updatenow.static line 12517.
[20130128.230348] E Detected events which require user notification during updatenow. Will send iContact the log
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
76
308
cPanel Access Level
Root Administrator
Re: Overnight Update Failed MySQL conflicts with mysql-5.0.77-4.el5_4.2.i38

From the output it appears you are using the MySQL RPM provided by RHEL/CentOS 5. Do you recall how you disabled the cPanel MySQL RPM? It appears this is not properly detected resulting in the aborted upgrade.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Re: Overnight Update Failed MySQL conflicts with mysql-5.0.77-4.el5_4.2.i38

Hello :)

Could you also submit a support ticket so we can take a closer look?

Submit A Ticket

Please provide us with the ticket number so we can update this thread.

Thank you.
 

mtbwacko

Well-Known Member
Nov 30, 2004
56
0
156
Re: Overnight Update Failed MySQL conflicts with mysql-5.0.77-4.el5_4.2.i38

Kenneth, thanks for the reply. I've never disabled the cPanel MySQL RPM and this is the first time an update failure has occurred for a server that's been online for years using automatic cPanel updates. I guess I'll submit a support ticket on this. Thanks!

From the output it appears you are using the MySQL RPM provided by RHEL/CentOS 5. Do you recall how you disabled the cPanel MySQL RPM? It appears this is not properly detected resulting in the aborted upgrade.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Re: Overnight Update Failed MySQL conflicts with mysql-5.0.77-4.el5_4.2.i38

Kenneth, thanks for the reply. I've never disabled the cPanel MySQL RPM and this is the first time an update failure has occurred for a server that's been online for years using automatic cPanel updates. I guess I'll submit a support ticket on this. Thanks!
Could you let us know the ticket number when you open the ticket so we can update this thread with the outcome?

Thanks.
 

mtbwacko

Well-Known Member
Nov 30, 2004
56
0
156
Re: Overnight Update Failed MySQL conflicts with mysql-5.0.77-4.el5_4.2.i38

Could you let us know the ticket number when you open the ticket so we can update this thread with the outcome? Thanks.
Yes, the cPanel ticket number is 3690013.

Thanks,
Greg
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Re: Overnight Update Failed MySQL conflicts with mysql-5.0.77-4.el5_4.2.i38

The ticket indicates this is the result of a rogue MySQL RPM installed on the system:

Code:
# rpm -qa|grep mysql-5
mysql-5.0.77-4.el5_4.2
You will notice this does not match the other installed MySQL RPMs:

Code:
MySQL-server-5.5.28-2.cp.1132
MySQL-devel-5.5.28-2.cp.1132
MySQL-client-5.5.28-2.cp.1132
MySQL-test-5.5.28-2.cp.1132
MySQL-shared-5.5.28-2.cp.1132
Removing the mysql-5.0.77-4.el5_4.2 RPM will allow the update to proceed.

Thank you.
 

JohnR

Member
Dec 12, 2002
8
0
151
I have the same problem.

[20130313.091648] error: Failed dependencies:
[20130313.091648] MySQL conflicts with mysql-5.0.95-1.el5_7.1.i386
[20130313.091648] W Exit Code: 254
[20130313.091648] ***** FATAL: Test install failed: error: Failed dependencies:
[20130313.091648] MySQL conflicts with mysql-5.0.95-1.el5_7.1.i386
[20130313.091648] The Administrator will be notified to review this output when this script completes
[20130313.091648] ***** FATAL: Error testing if the RPMs will install: Died at /usr/local/cpanel/scripts/updatenow.static line 12521.

This is on a server with only three accounts and I get notified of any logins as I should be the only one logging in. Not sure how a "rogue" version would get installed.

What is the best way to get around this without loosing data or causing downtime?
 

linehooks

Registered
Mar 14, 2013
2
0
1
cPanel Access Level
Root Administrator
Hi,

I have the same problem :( will removing the RPM delete my databases?

It there a way of remedying this without much downtime please?

Help?!

[20130313.212633] All files Staged
[20130313.212633] Testing if the newly downloaded RPMS can be installed without conflict
[20130313.212633] Testing RPM transaction
[20130313.212633] error: Failed dependencies:
[20130313.212633] MySQL conflicts with mysql-5.0.77-4.el5_4.2.i386
[20130313.212633] W Exit Code: 254
[20130313.212633] ***** FATAL: Test install failed: error: Failed dependencies:
[20130313.212633] MySQL conflicts with mysql-5.0.77-4.el5_4.2.i386
[20130313.212633] The Administrator will be notified to review this output when this script completes
[20130313.212633] ***** FATAL: Error testing if the RPMs will install: Died at /usr/local/cpanel/scripts/updatenow.static line
 

Eric

Well-Known Member
Nov 25, 2007
752
12
143
Texas
cPanel Access Level
Root Administrator
Howdy,

If you use the rpm command

Code:
rpm -e --nodeps --allmatches --justdb <RPMNAME>
It will only remove entry of the RPM from the RPM database. No binaries or files will be touched.

Thanks!