The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Case 72257] Monthly BackUps on New BackUp Version Fails

Discussion in 'Data Protection' started by PCZero, Jul 1, 2013.

  1. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    I believe there is a bug in the new back up version. Here is the issue.

    Back Up Settings:

    Back Up Enable
    Compressed
    Daily (all days, 4 retained)
    Monthly (both days 1 retained)
    Back Up Accounts (all accounts selected for new version)
    Access Logs Disabled
    Bandwidth Enabled
    Local DNS Enabled
    Databases Per Account Only
    Directory /backup
    Retain No
    Mount Disable
    Additional Destination FTP (To a local box, set up and validated)

    Results:

    All daily back up perform exactly as designed. gzip files are created in /backup and ftp to my local machine is successful in the YYYY-MM-DD folders. Creation and deletion of folders is executed exactly as desired.

    ERROR: On the 1st when the monthly back up hits, the FTP fails after 2-3 accounts have been sent to my local machine (in WHM gets flagged as not valid and is disabled. This occurs whether or not I have the Disable Destination That Fail Validation check box ticked). In addition to the folder for YYYY-MM-01 being created a MONTHLY folder is created and another YYYY-MM-01 folder is created there. The FTP sends the back ups to the higher level YYYY-MM-01 folder and NOT into the one located in the MONTHLY folder.

    When I noticed this error I manually ran the back up several times with and without MONTHLY back up selected. On every occasion that MONTHLY WAS selected, the error occurred. Every instance where I did NOT select monthly back ups everything went well and the back up completed successfully.

    Please advise...

    - - - Updated - - -

    Please also note that the check box for automatic disable of invalid remotes ALWAYS is ticked after config is saved. Even if you uncheck it and save, it is ticked when you go back into backup config.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you open a support ticket so we can attempt to reproduce this behavior on your server? You can open a ticket via:

    Submit A Ticket

    Remember to post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    I would but it says I need an ID/PW. Dont have one. Just work on the issue form here. You have all the info you need.
     
  4. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    Go it it finally. Request ID is 4284231.
     
  5. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    This issue still exists. The monthly back up fails on a remote transfer and shuts down the FTP saying it is not valid. It works fine on all daily back ups though. However because of the inability of the cpanel people to get to my server (even though I have turned off EVERY level of security and thus left the box wide open) I am shutting down working on the bug. If you guys ever get around to test bedding this and fixing it let me know. I have re-enabled all security and removed all keys etc you had me ass. I cannot afford to leave a production server that wide open for days while you try to figure out what you are doing. Thank for trying... You can close the ticket now, I am done messing with it.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Per the support ticket (#4284231), there is currently an active attempt to reproduce this issue on a test server so that we do not have to access your server directly. You will receive updates from our analysts on this ticket as more information is available, and I will update this thread with the outcome.

    Thank you.
     
  7. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    Thanks to Brian Warren of cPanel this issue has been identified as a bug and is being address at internal case 72257. Hopefully we will see a fix soon. Thank you very much Brian for your continued attention to this.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, internal case number 72257 is now open to address this issue. For anyone else reading this thread, you may experience this issue when all three of the following conditions are met:

    1. You enable monthly backups.
    2. You generate backups on a day when monthly backups generate (or set server time to the 1st or 15th, according to which day you have selected).
    3. You uncheck "Retain backups in the default backup directory."

    The current workaround is to ensure "Retain backups in the default backup directory" is not disabled.

    Thank you.
     
  9. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    Just a warning to all users. If you enable the "Retain backups in the default backup directory" option you can fill up your drive very very quickly...
     
  10. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    Was this by chance addressed in the 11.38.1.16 update? There is no change log listing the updates made for this release.
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I believe you are referring to cPanel version 11.38.1.6. A resolution for case number 72257 has not yet been pushed out to a public build of cPanel. The most recent 11.38.1 build (11.38.1.13) was a targeted security release.

    Thank you.
     
  12. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    My typo. Was talking about .13...
     
  13. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    526
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Earth
    cPanel & WHM 11.40 Changelog

    - 11.39.0.8 2013-07-23

    -- Fixed case 72257: Improve file cleanup when both daily and monthly need to run.
     
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    A resolution for case 72257 was implemented with cPanel version 11.38.2.0. This version is currently available in the "Current" build tier, and will work it's way down to the other build tiers over time per standard protocol. The change log is available at:

    cPanel - Change Log

    Thank you.
     
  15. craigedmonds

    craigedmonds Well-Known Member

    Joined:
    Oct 29, 2007
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Europe
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi,

    I notice this thread is a couple of months old but I have recently reverted to the new backup system and today (the 15th) have received an email from the server saying...

    +===================================+
    | Transport Disabled |
    +===================================+
    | Name: backup.XXXXX.com
    | Type: FTP
    | Remote Host: backup.XXXX.com
    |
    | Reason: Transport surpassed error threshhold with “4” errors
    +===================================+

    I am running WHM 11.38.2 (build 7).

    Is there a solution for is?
     
  16. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Have you verified that you can upload files to your remote FTP server manually through SSH? Also, do you notice any specific errors in the /usr/local/cpanel/logs/cpbackup_transporter.log file?

    Thank you.
     
  17. craigedmonds

    craigedmonds Well-Known Member

    Joined:
    Oct 29, 2007
    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Europe
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi,

    Here is some unusual entries in the /usr/local/cpanel/logs/cpbackup_transporter.log file.

    [2013-10-13 12:54:39 +0100] warn [cpbackup_transporter] Upload attempt failed: “Cpanel::Transport::Files::put” attempted to validate a file that does not exist: /home/backup/2013-10-13/accounts/havergal.tar.gz at /usr/local/cpanel/Cpanel/LoggerAdapter.pm line 26
    Cpanel::LoggerAdapter::warn(Cpanel::LoggerAdapter=HASH(0x3c14138), 'Upload attempt failed: \xE2\x80\x9CCpanel::Transport::Files::put\xE2\x80\x9D attempted to validate a file that does not exist: /home/backup/2013-10-13/accounts/havergal.tar.gz') called at /usr/local/cpanel/Cpanel/Backup/Queue.pm line 219
    Cpanel::Backup::Queue::transport_backup::attempt_to_upload_file(Cpanel::Backup::Queue::transport_backup=HASH(0x3be4768), Cpanel::Transport::Files::FTP=HASH(0x448b7c0), '/home/backup/2013-10-13/accounts/havergal.tar.gz', '/maggie.hsws.com/2013-10-13/havergal.tar.gz', Cpanel::LoggerAdapter=HASH(0x3c14138)) called at /usr/local/cpanel/Cpanel/Backup/Queue.pm line 135
    Cpanel::Backup::Queue::transport_backup::process_task(Cpanel::Backup::Queue::transport_backup=HASH(0x3be4768), cPanel::TaskQueue::Task=HASH(0x44c63c0), Cpanel::LoggerAdapter=HASH(0x3c14138)) called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/TaskQueue.pm line 571
    eval {...} called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/TaskQueue.pm line 574
    cPanel::TaskQueue::__ANON__() called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/StateFile.pm line 246
    eval {...} called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/StateFile.pm line 246
    cPanel::StateFile::Guard::call_unlocked(cPanel::StateFile::Guard=HASH(0x3bfb7d8), CODE(0x44c63f0)) called at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/cPanel/TaskQueue.pm line 579
     
  18. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  19. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    983
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    This is obviously a bug. Can you please fix the backups, so that when options 1 & 2 are ticked, and option 3 is unticked (i.e. don't retain local backups) that remote backups will still work fine. For clients, most often VPS clients with limited HDD space, this is a big problem since their server's HDD could be more than 50% full, which means there isn't enough space for the accounts + backups without adding (and paying) for another HDD.
     
  20. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, this was in-fact a bug. When internal cases are referenced, it means a bug report is open to address the issue. In this particular instance, it was stated that internal case 72257 was opened to address the issue. However, since that time, a resolution was already pushed out with cPanel version 11.38.2.0. Any versions higher than that (including 11.40 and 11.42) should no longer experience this issue. If the issue continues, it would be due to a new bug, and thus you should submit a new bug report via:

    Submit A Bug Report

    You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page