The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Case 73321] Disabling SpamAssassin does not alter acl_outgoing_spam_scan

Discussion in 'E-mail Discussions' started by jasgot, Jul 12, 2013.

  1. jasgot

    jasgot Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    55
    Likes Received:
    1
    Trophy Points:
    6
    I've been struggling with this for a long time, I now admit defeat and am looking for some help.

    Every outgoing message from my users generates this error:

    2013-07-12 13:14:01 1Uxguu-0004BO-Sa spam acl condition: warning - spamd connection to 127.0.0.1, port 783 failed: Connection refused
    2013-07-12 13:14:01 1Uxguu-0004BO-Sa spam acl condition: all spamd servers failed

    The problem is that I am not using SpamAssassin and I do not have SPAMD running. I cannot figure out how or why EXIM is trying to access SPAMD.

    I was watching a mail queue run one day and saw this, not sure if it helps:
    LOG: MAIN
    cwd=/var/spool/exim_10_arg: /usr/sbin/exim -c /etc/exim_outgoping.conf -v -t -oem -oi -f <> -E1usV9E-0006kw-0k
    trying server 127.0.0.1, port 783

    LOG: MAIN PANIC
    spam acl condition: warning - spamd connection to 127.0.0.1, port 783 failed: Connection Refused

    LOG: MAIN PANIC
    spam acl condition: all spamd servers failed


    If you need information or logs, please let me know.

    Jason
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,813
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Check to ensure "Enable SpamAssassin spam filter" in selected in "WHM Home » Server Configuration » Tweak Settings" under the "Mail" tab. Also, ensure that "spamd" is enabled in "WHM Home » Service Configuration » Service Manager". You can verify the service is running with the following command:

    Code:
    /scripts/restartsrv_spamd --status
    I also suggest checking to ensure connections to port 783 are not blocked by any firewall rules you have enabled.

    Thank you.
     
  3. jasgot

    jasgot Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    55
    Likes Received:
    1
    Trophy Points:
    6
    I do not use SpamAssassin. I need to stop EXIM from trying to use it.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,813
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    If you want it disabled, check to ensure "Enable SpamAssassin spam filter" in "not" selected in "WHM Home » Server Configuration » Tweak Settings" under the "Mail" tab. Also, ensure that "spamd" is disabled in "WHM Home » Service Configuration » Service Manager". Is it still running after you confirm it's disabled in those two locations?

    Thank you.
     
  5. jasgot

    jasgot Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    55
    Likes Received:
    1
    Trophy Points:
    6
    It is disabled. Enable SpamAssassin spam filter in HOME>Server Configuration>Tweak Settings>Mail is set to OFF.

    SpammAssassin IS disabled.

    I am trying to stop Exim from trying to access SpamAssassin. SpamAssassin is NOT running.
     
  6. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
  7. jasgot

    jasgot Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    55
    Likes Received:
    1
    Trophy Points:
    6
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,813
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Have you tried backing up your Exim configuration and then resetting it? You can backup your Exim configuration via the "Backup" tab in:

    "WHM Home » Service Configuration » Exim Configuration Manager"

    Then, browse to the "Reset" tab and choose "Reset the entire Exim configuration to the default settings provided with cPanel & WHM".

    If the issue continues, feel free to submit a support ticket so we can take a closer look:

    Submit A Ticket

    You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  9. jasgot

    jasgot Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    55
    Likes Received:
    1
    Trophy Points:
    6
    RESOLVED: spam acl condition: warning - spamd connection to 127.0.0.1, port 783 failed:

    There was a setting in the Exim Configuration Editor > Basic Editor > "Scan outgoing messages for spam and reject based on SpamAssassin® internal spam_score setting" which was set to On but greyed out so you could not disable it. We had to manually edit the /etc/exim.conf.localopts file to get rid of it.

    This fixed the problem. I have not seen the SPAMD errors in two days.

    acl_outgoing_spam_scan=1
    changed to
    acl_outgoing_spam_scan=0
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,813
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Thank you for updating us with the solution. I have reproduced this issue on a test server and have opened an internal case to address this issue. For reference, the internal case number is 73321.

    Thank you.
     
  11. allandb

    allandb Registered

    Joined:
    Sep 9, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Has this issue been resolved? Strangely, I noticed the same SpamAssassin connection problem on port 783 popping up for accounts with auto-responders enabled - and only for these - and observed the same greyed out setting which jasgot found.

    Hence, I applied the manual fix, which has resolved it.

    But I wonder if there is a risk that this setting will regress to the faulty state - although I assume exim.conf.localopts should be save?

    WHM 11.38.2 (build 6).
     
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,813
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    A resolution for this case has not yet been implemented. The manual workaround is still to manually disable the "acl_outgoing_spam_scan" option in the Exim configuration or deselect the option in WHM. The issue should not reoccur after implementing the manual workaround.

    Thank you.
     
  13. pawlectro

    pawlectro Member

    Joined:
    Dec 4, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I wanted to let cPanel know this is still an issue. I just went through this exactly after disabling SpamAssassin in Tweak Settings, Service Manager, and in Exim config. Disabling alone does not solve the issue. The extra steps as noted above still have to be taken otherwise exim still tries to connect to spamd and times out because the service is not running.
     
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,813
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The internal case is still open at this time. A link to this thread has been provided, and a recent example was added to the internal case. There's currently no specific time frame available on a resolution, but I will update this thread with more information as it becomes available.

    Thank you.
     
Loading...

Share This Page