The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Case 83461] MailMan 404 Error when Managing List

Discussion in 'E-mail Discussions' started by NW-Dan, Sep 25, 2013.

  1. NW-Dan

    NW-Dan Member

    Joined:
    Mar 16, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I've googled for this answer and searched but can't find much. I've just enabled this in my WHM and added a list, but am receiving a 404 after I click manage. I've tried adding the mail. prefix but that didn't help. Any other suggestions?

    I've disabled and reenabled, the only thing I didn't try was reinstalling via command line. I'd like to see if anyone else found a fix for this before I do that.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,766
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. NW-Dan

    NW-Dan Member

    Joined:
    Mar 16, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    It does. The actual account itself is on a dedicated IP, but when the mailmail link is clicked its looking for it through the hostname. I use cpanel dnsonly if it makes a distance.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,766
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Does the hostname also resolve to the IP address of the server? If so, try running the following command:

    Code:
    /scripts/fixmailman
    Thank you.
     
  5. cinusik

    cinusik Active Member

    Joined:
    Jul 31, 2003
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I have exactly the same problem on multiple servers running 11.40.0.26. Some of them are CentOS some CloudLinux so it is not related to any specific linux distribution.
    There is 404 error or "can't open page" error every time I click Manage next to mailing list.
    Already tried upcp --force, /scripts/fixmailman and also reinstalled mailman but without any success.
    Opened ticket - id 4407575
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,766
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Internal case 83461 is open to address the issue where links in the mailman management interface fail to function correctly when using the .pl tld. The current workaround is to add a trailing "/" to the end of the URL. There is currently no time frame available for when a resolution will be implemented.

    Thank you.
     
Loading...

Share This Page