The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Case 86561] CGIEMAIL error

Discussion in 'E-mail Discussions' started by bear, Dec 27, 2013.

  1. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Have someone that's suddenly seeing an error in using CGIEMAIL (they've been using it here for ages), and I'm not finding the cause. Hoping someone could point me to what to look for here. The error, when submitting the form that uses it:

    Anyone have an idea what's up here?
    CENTOS 6.5 x86_64 standard – wbtms3
    WHM 11.40.1 (build 8)
     
  2. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Realized I hadn't included the form call, so here that is:
    domain.tld/cgi-sys/cgiemail/cgi-bin/the_template.txt (file and domain altered)
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's possible this is related to internal case number 86561. Could you update the permissions on /usr/local/cpanel/bin/sendmail to 4755 and let us know if the issue persists?

    Thank you.
     
  4. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Just came back to post that support provided that same info. Yes, it fixes it. Thanks Michael!
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, there is an internal case open to address this issue. For reference, the case number is 86561. The temporary workaround at this point is to modify the permissions on /usr/local/cpanel/bin/sendmail to 4755:

    Code:
    chmod 4755 /usr/local/cpanel/bin/sendmail
    Thank you.
     
  6. Froggie

    Froggie Registered

    Joined:
    Jun 5, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    That looks like the solution to my problem too but I have unfortunately no idea how to modify the permissions:confused: Would you be able to explain to me how to go about it?
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Your access level is listed as "Website Owner". You will need to contact your web hosting provider to inform them of this issue/solution.

    Thank you.
     
  8. Froggie

    Froggie Registered

    Joined:
    Jun 5, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    :)Thank you. I'll do that straight away.
     
  9. Skotty Dawg

    Skotty Dawg Registered

    Joined:
    Jul 5, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I'm getting the same 500 issue and I don't know how to access the "/usr/local/cpanel/bin/sendmail to 4755" or whatever to change it. The CGI form was working great back in May. Please help!
     
    #9 Skotty Dawg, Jul 5, 2014
    Last edited by a moderator: Jul 7, 2014
  10. hiredgeek

    hiredgeek Registered

    Joined:
    Jul 9, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I believe you have to shell (terminal) into the root of the server to change those permissions.

    I changed my permissions but it only temporarily fixed the issue. After about a day or 2, the permissions get magically set back to 755. I change them to 4755 again and it works, but only for bit, so I keep on having to do this over and over. Any ideas?
     
  11. tross

    tross Registered

    Joined:
    Feb 6, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I have the same issue with permissions reverting to 755. I could put a cron job to change them everyday but that is not a good solution. How can we stop the changes?
     
  12. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    The only way to keep it as 755 (without setting a cron as above) is to set it then make the file immutable (chattr +i /file/location/filename). Cpanel will complain about that periodically, and it prevents updating sendmail, so if the issue were resolved instead I'd be much happier. It appears to affect only CGIEMAIL, so if I can convince the one user on the box to change what they use, I'd then disable that.
     
  13. tross

    tross Registered

    Joined:
    Feb 6, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the suggestion. I too was worried that it might cause some problem with cpanel updates. I hope they can get this fixed.
     
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Internal case number 86561 was addressed in cPanel version 11.42.1.18:

    Fixed case 86561: Updated cpanel-cgiemail to 1.6-5.cp1136.

    Thank you.
     
  15. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Fantastic news, Michael. I must have missed the note about it being resolved.
     
  16. hiredgeek

    hiredgeek Registered

    Joined:
    Jul 9, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Unfortunately permissions still got changed and I'm on version 11.44.1 (build 11) .
    I have two servers and it's only doing it on one of them.
    I manually did a chmod again, and now I set up a chron to run every 5 minutes. :confused:
     
  17. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  18. hiredgeek

    hiredgeek Registered

    Joined:
    Jul 9, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Ticket #5441941
    Thank you
     
  19. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    To update, this ticket was closed automatically due to a lack of response to our request for authentication details. Please feel free to reply to that ticket with the requested information if you want us to take a closer look.

    Thank you.
     
  20. Michael-MS

    Michael-MS Well-Known Member

    Joined:
    Apr 16, 2003
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Our server is having the same problem. I did the chmod 4755 /usr/local/cpanel/bin/sendmail to fix it and it reverted back after the last update. I will open a ticket. #5634511
     
    #20 Michael-MS, Oct 29, 2014
    Last edited: Oct 29, 2014
Loading...

Share This Page