[Case 93293] partial (incomplete) emails from Cpanel

Feemish

Active Member
Oct 26, 2005
25
0
151
WHM 11.42.0 (build21)

Recently I've started receiving partial emails from Cpanel after Back up.

Usually I receive
[cpbackup] Backup complete on myserver.co.uk
with the message content;
"Please see the attached log file."
and the said log.txt file is attached.

However, for the last week or so I am also receiving partial emails with the same title, but there is no attachment and the message content is;
""Please see the attached log fil "

literally ending in fil

as if the message was sent before the content was finished..
Does anyone have any idea what this is all about?

Thanks
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

Are you using the legacy backup system? If so, please review the backup logs in /usr/local/cpanel/logs/cpbackup and let us know if you notice any problems with the backup generation. Does it complete successfully?

Thank you.
 

Feemish

Active Member
Oct 26, 2005
25
0
151
What is the legacy back up system?

The directory /usr/local/cpanel/logs/cpbackup seems to have successful back ups.

Everytime my server backs up, I now receive 2 emails.
The first is the incomplete email;
subject: [cpbackup] Backup complete on *myserver*.co.uk
content: Please see the attached log fil
no attachment

Then a second or so later I receive the complete email as I expect
subject: [cpbackup] Backup complete on *myserver*.co.uk
content: Please see the attached log file
attachment: 1394643602.log.txt

So the back up does seem to be completing properly, but for some reason, there is this spurious partial email sent out first?
 

Feemish

Active Member
Oct 26, 2005
25
0
151
Sorry I thought you meant 'legacy' meaning some older version of backup.

Yes legacy back up is enabled, and seems to be backing up fine.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
So, to clarify, the issue is only with the notification you are receiving? It's possible there is an extra cron job setup. Could you open a support ticket so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

Feemish

Active Member
Oct 26, 2005
25
0
151
It looks like my hosting support people have found the issue.

Evidently 'pager' had become enabled in contact methods.

I didnt enable 'pager' myself. Could this have been enabled during an update??

message from my support people;
"I think the problem relates to the different contact methods. You had pager enabled - although WHM had no pager number - it was somehow using the same email address. That suggests that it was deliberately trying to cut off the message because, obviously, pagers have limited amount of space for text, etc."
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
There is an internal case open to address the pager notification issue. For reference, the case number is 93293. There is currently no specific time frame on when a resolution might be pushed out, but the temporary workaround is to set the "Pager" setting to "Disable" in "WHM >> Contact Manager".

Thank you.