[case CPANEL-12822,case CPANEL-13105] phpMyAdmin max_input_vars error

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
I just have a couple of questions, as this is still not solved for me. Which php.ini has the cPanel update modified? All I see is the 1000 value for max_input_vars instead of 10000:
You should see the following output after updating to cPanel 64.0.24 or newer:

Code:
# grep max_input_vars  /usr/local/cpanel/3rdparty/php/56/etc/phpmyadmin/php.ini
max_input_vars = 10000
If not, check to verify you disabled any custom workarounds you implemented when you first encountered the issue.

Thank you.
 

bj3782

Registered
May 30, 2017
4
2
3
Brisbane
cPanel Access Level
Reseller Owner
You should see the following output after updating to cPanel 64.0.24 or newer:

Code:
# grep max_input_vars  /usr/local/cpanel/3rdparty/php/56/etc/phpmyadmin/php.ini
max_input_vars = 10000
If not, check to verify you disabled any custom workarounds you implemented when you first encountered the issue.

Thank you.
I was wondering if/when cPanel 64.0.24 is/will be pushed to the Stable tier? I've had the max_input_vars error as well but the hosting company I'm with has control over updates. They said cPanel should automatically update when it's pushed to the stable tier. Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
I was wondering if/when cPanel 64.0.24 is/will be pushed to the Stable tier? I've had the max_input_vars error as well but the hosting company I'm with has control over updates. They said cPanel should automatically update when it's pushed to the stable tier. Thanks!
Hello @bj3782,

64.0.24 was published to the STABLE build tier today. Automatic updates occur when the "upcp" cron job runs on the server, so the server should update to this version within 24 hours if your hosting provider has enabled automatic updates.

Thanks!
 

Havri

Well-Known Member
Oct 28, 2013
86
19
8
cPanel Access Level
Root Administrator
Hello,

I still get this error when I go to PHPMyAdmin -> Designer. I'm attaching a screenshot. My cPanel version is :

Code:
[[email protected] zapatoro4]# cat /usr/local/cpanel/version
11.64.0.24
The max_input_vars value is indeed 10000:

Code:
[[email protected] php]# grep max_input_vars  /usr/local/cpanel/3rdparty/php/56/etc/phpmyadmin/php.ini
max_input_vars = 10000
What I modified to solve this error was to edit this file:

/usr/local/cpanel/3rdparty/php/56/etc/php.ini

and not this one:

/usr/local/cpanel/3rdparty/php/56/etc/phpmyadmin/php.ini

Will this fix be incorporated into cPanel or should I just modify it every time I need it? Furthermore, will cPanel overwrite all of my modifications?

Thank you.
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello @Havri,

The issue should have been addressed with the resolution included in cPanel 64.0.24. Could you open a support ticket using the link in my signature so we can take a closer look at your system?

Thank you.
 

Havri

Well-Known Member
Oct 28, 2013
86
19
8
cPanel Access Level
Root Administrator
Hello,

There is another bug related to this. The issue ID is CPANEL-13518. The reason was:

"the issue appears when I enable the "PHP-FPM Service for cPanel Daemons" in "WHM >> Service Configuration >> Service Manager." This causes phpMyAdmin to use the /usr/local/cpanel/3rdparty/php/56/etc/php.ini file instead of the one specific for it. I only identified this when noticing it was disabled on my test server but enabled on yours."

Thank you.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello,

There is another bug related to this. The issue ID is CPANEL-13518. The reason was:

"the issue appears when I enable the "PHP-FPM Service for cPanel Daemons" in "WHM >> Service Configuration >> Service Manager." This causes phpMyAdmin to use the /usr/local/cpanel/3rdparty/php/56/etc/php.ini file instead of the one specific for it. I only identified this when noticing it was disabled on my test server but enabled on yours."

Thank you.
I'll monitor this case and update this thread once we publish a resolution.

Thank you.
 

Giannis

Well-Known Member
PartnerNOC
Jun 22, 2005
67
0
156
I am having the same issue.
I updated /usr/local/cpanel/3rdparty/etc/php.ini but after cpanel update it was changed.
 

Havri

Well-Known Member
Oct 28, 2013
86
19
8
cPanel Access Level
Root Administrator
Hello,

Yes, well the bug fix will probably solve this problem. PHPMyAdmin should read /usr/local/cpanel/3rdparty/php/56/etc/phpmyadmin/php.ini and not this one /usr/local/cpanel/3rdparty/php/56/etc/php.ini when having the "PHP-FPM Service for cPanel Daemons" enabled.
 

rarod

Active Member
Apr 20, 2017
36
2
8
Spain
cPanel Access Level
Root Administrator
Same issue here. PHPMyAdmin with PHP-FPM is using /usr/local/cpanel/3rdparty/php/56/etc/php.ini instead of /usr/local/cpanel/3rdparty/php/56/etc/phpmyadmin/php.ini

I will apply the workaround again.
 

Havri

Well-Known Member
Oct 28, 2013
86
19
8
cPanel Access Level
Root Administrator
Hello,

You could also check if you're using "PHP-FPM Service for cPanel Daemons" in "WHM >> Service Configuration >> Service Manager.". After disabling this service, check if the problem is solved.

Good luck.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello,

To update, the resolution associated with CPANEL-13518 is included with cPanel version 66.0.9:

Fixed case CPANEL-13518: Increase max_input_vars for cpanel_php_fpm to accomodate PHPMyAdmin.

Thank you.