The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

catchall :blackhole:

Discussion in 'General Discussion' started by jamesbond, Dec 21, 2002.

  1. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    In the Mail Default Address section I changed the setting for unrouted mail to :blackhole:

    What I noticed is that all e-mail addressed to the default e-mail account is also vanishing into the blackhole!

    It's not supposed to work like that is it??

    I'm running S101.
     
  2. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    So you set the default address (catchall) to :blackhole:, but you have specific addresses forwarding the the username for the account?
     
  3. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    [quote:ac58c1effd][i:ac58c1effd]Originally posted by JustinK[/i:ac58c1effd]

    So you set the default address (catchall) to :blackhole:, but you have specific addresses forwarding the the username for the account?[/quote:ac58c1effd]

    No, I haven't set any forwards, I thought only unrouted e-mail would go to :blackhole:

    So I should set a forward : defaultaddress@domain.com -& anotheraddress@domain.com ?
     
  4. mrprez

    mrprez Well-Known Member

    Joined:
    Jun 14, 2002
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    16
    If you setup the default email to go to blackhole then all of them will go to blackhole including the default. I don't there is a way around this.
     
  5. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    My issue looks relevant to this thread. It appears that forwarders/aliases are not considered 'routable' addresses by CPanel, so if I set the default address to be :blackhole: (to cut down on the massive spam I get), then all of my forwarders/aliases are rendered useless. This is a major issue!

    I have a number of cusomters also complaining about this. Am I suppose to tell them they only have two options: 1) kill the spam but you can't have any forwarders/aliases or 2) deal with the spam to keep them?!?

    Does everyone else find this to also be the case?

    Jaz
     
  6. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    16
    A quick work-around is to add a valid email account in addition to the forwarded email account.

    Ex. If you have a forward setup as johnq@yourdomain.com, simply add an email address called johnq@yourdomain.com. The mail will still forward. You don't have to login to the johnq@yourdomain.com email since it forwards. Then, occasionally delete and re-add the email address to clear the space usage. Deleting the email deletes all email in that box.

    Not ideal, but at least the forwards will get through.

    As for me, I don't use the blackhole thingy. I have found it to be buggy and a pain in the ass. That is my work around! ;)
     
  7. host95

    host95 Member

    Joined:
    Jan 21, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Will this work on cpanel? Set up a POP account called /dev/null. Then forward the address that gets most of the spam, example@domain.com, to the /dev/null address. What you're doing is setting up a real blackhole. Neither the /dev/null account nor the example@domain.com will ever hold messages so there would be nothing to empty. This does work on other systems. Please try this and let us know.

    Thanks
     
  8. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    :blackhole: does the same thing. Forwarders should still forward even if the default account is set to :blackhole:
     
  9. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    [quote:166824d328][i:166824d328]Originally posted by JustinK[/i:166824d328]

    :blackhole: does the same thing. Forwarders should still forward even if the default account is set to :blackhole: [/quote:166824d328]

    Forwarders will only work if they are going to an external address. If you configure one for an internal address (effectively an alias) and configure the default account to :blackhole:, the mail to the forwarder will just go to the black hole. Try it yourself. I've done it over and over again. I've even created a forwarder that sends mail to :blackhole: and then set the default account to be that forwarder (so that it isn't the true 'base' email account) to see if it has any effect, but the same results occur. This also goes for :fail:. Half of my support time is spent with this stupid problem.

    Essentially, if your customer configures :blackhole: or :fail: on their default account (using any of the possible methods above) all internal forwarders will fail.

    Jaz
     
  10. host95

    host95 Member

    Joined:
    Jan 21, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Maybe Cpanel's text should be changed.

    Click on &Set Default Account& in Cpanel's user interface and you'll get this &&

    Special Notes: There is an alternate option (you must specify the colons :)):

    :blackhole:

    Delete all messages that are not addressed to a valid user. &&

    Looks like some clients are not using :blackhole: appropriately. Maybe a warning should be added to the &E-mail Forwarders& set up page?
     
  11. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    Ok so just so I set this up right:

    Set default account to :blackhole:
    (or did you set a forwarder to blackhole and then set the default account to go to that forwarder?)
    Create a forwarder to go to an on-server address.
    Send e-mail to forwarder that goes to an on-server address.

    And then the mail shouldn't go through correct?


    Just to note, if you set the default account to :blackhole:, :fail: or anything that points to those, the account's username won't receive mail. You would need to create an alias for it manually in the domain's valias file.

    For example, the cpanel account username: jack
    Default address set to :blackhole:
    Mail to jack@jacksdomain.com will go to the blackhole unless an alias is manually created for it.
     
  12. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    [quote:cc893f7c50][i:cc893f7c50]Originally posted by JustinK[/i:cc893f7c50]

    Ok so just so I set this up right:

    Set default account to :blackhole:
    (or did you set a forwarder to blackhole and then set the default account to go to that forwarder?)
    Create a forwarder to go to an on-server address.
    Send e-mail to forwarder that goes to an on-server address.

    And then the mail shouldn't go through correct?


    Just to note, if you set the default account to :blackhole:, :fail: or anything that points to those, the account's username won't receive mail. You would need to create an alias for it manually in the domain's valias file.

    For example, the cpanel account username: jack
    Default address set to :blackhole:
    Mail to jack@jacksdomain.com will go to the blackhole unless an alias is manually created for it.[/quote:cc893f7c50]

    For the first part, correct on both fronts (we tested it it both ways).

    In our first test, we performed these steps (assuming mydomain.com is the domain on our server):

    1) Set the default account to :blackhole:
    2) Created an email account for john@mydomain.com
    3) Create a forwarder for johnny@mydomain.com pointing to john@mydomain.com
    4) Sent an email to johnny@mydomain.com from an offsite email account

    The message never makes it into the john@mydomain.com account. Since it doesn't bounce either, it has defintely gone into the blackhole. If we remove the blackhole, it will go through just fine.

    Jaz
     
  13. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    Is john a popmail account or is john the cpanel username for that account?
     
  14. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    It's a POP3/IMAP account, hence why we said the create the account (the CPanel account would already be there).

    Jaz
     
  15. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    Just making sure. Want to make the test as exact as possible. :)
     
  16. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    Tested with cpanel account: jane
    1. Logged into cpanel, went the the default address section and changed the default address to :fail:
    2. Went to the mail account section and created a new popmail account called thebox@janesdomain.com.
    3. Went to the mail forwarder section and created a forwarder &gotothebox@janesdomain.com& which forwards to thebox@janesdomain.com.

    4. Sent test e-mails:
    one to jane@janesdomain.com - status: blackhole
    one to anything@janesdomain.com - status: blackhole
    one to thebox@janesdomain.com - status: delivered
    one to gotothebox@janesdomain.com - status: delivered
     
  17. scsiman

    scsiman Registered

    Joined:
    Jan 29, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Why does it have to work that way?

    In the docs, for the Set Default Address it says all unrouted email will be directed to :blackhole: or :fail:

    Why doesn't CPanel see the main account as a valid adderss?
    How can someone go about getting this fixed?

    In your example, if I was Jane I would be upset!

    I chose my main account name because that is what I wanted people to email me on, not some other account that I have to create and then use.

    This just does not make sence to me, can someone explain this?
     
  18. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    [quote:78dfcedf42][i:78dfcedf42]Originally posted by JustinK[/i:78dfcedf42]

    Tested with cpanel account: jane
    1. Logged into cpanel, went the the default address section and changed the default address to :fail:
    2. Went to the mail account section and created a new popmail account called thebox@janesdomain.com.
    3. Went to the mail forwarder section and created a forwarder &gotothebox@janesdomain.com& which forwards to thebox@janesdomain.com.

    4. Sent test e-mails:
    one to jane@janesdomain.com - status: blackhole
    one to anything@janesdomain.com - status: blackhole
    one to thebox@janesdomain.com - status: delivered
    one to gotothebox@janesdomain.com - status: delivered[/quote:78dfcedf42]

    Did you set it to :fail: or :blackhole:? You mention both. Try it with :blackhole: if you actually used :fail:. We do not get the same results.

    Jaz
     
  19. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    Woops, had :fail: on my mind. Actually put :blackhole: during the test though.

    scsiman, I'm not sure. I believe it worked properly before, but people had complained about not being able to block off mail to the account so maybe cpanel changed that? You can create a forwarder manually if you directly edit the /etc/valiases/domain.ext file (domain.ext being the domain you're editing the valiases file for). All you have to do is add:
    mainuser@domain.com: mainuser

    Once done, mail gets through fine. :)
     
  20. scsiman

    scsiman Registered

    Joined:
    Jan 29, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    hmm, alright I guess it seems like a lot of work to manually edit that, but I can see why it was done.
     

Share This Page