Catchall mailbox has stopped working - Help

scrocker1946

Registered
Dec 23, 2005
3
0
151
I provide computer services for a small business whose site is hosted using cpanel. I sometimes assist our Webmaster with setting up email accounts, etc. For several years we have configured the local mailbox "dumpster" as our catchall account, and it has worked fine, receiving all our misaddressed mail.

About 2 months ago, the dumpster account mysteriously stopped working. Mail addressed explicitly to that account goes through, but mail sent to nonexistent addresses bounces. The bounce process consists of an initial warning message ("delivery has been delayed") which is sent about 1 1/2 hours after the original message. Another "delivery delayed" message is sent about a day later, and a final "delivery failed" message a day after that.

This began to occur about the same time as some other behavior changes of the mail server. I am wondering if an update to cpanel might have invilved some Exim configuration changes which make it incompatible with the use of the catchall account. (I checked the obvious configuration options for the catchall account itself, everything is set correctly there).

(If it might be a clue, the other behavior change is as follows. If we send outgoing email via our SMTP server, and the email is addressed to a misspelled user name within our domain, that mail is now rejected by the SMTP server. Our client reports it as unsent. This never used to happen.)

I am unfamiliar with Exim configuration. If anybody has any knowledge of this problem, please help. Any advice will be appreciated.

Thanks,
-Steve
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
You really need to check the contents of /etc/valiases/domainname.com where domainname.com is the domain in question. If there is a default (catchall) address it would be the last entry something similar to:

*: username
 

scrocker1946

Registered
Dec 23, 2005
3
0
151
Checked the file -looks okay

chirpy said:
>You really need to check the contents of /etc/valiases/domainname.com where domainname.com is the

>domain in question. If there is a default (catchall) address it would be the last entry something similar to:
>
>*: username

I checked that file. The last entry reads as follows -

*: [email protected]

This appears to be correct. Any further thoughts?

Thanks,
-Steve
 

ProLamer

Active Member
May 17, 2005
43
0
156
edit /etc/vdomainaliases/domain.com and remove any entry in that file and try again.

It works for me.