The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ccpop bug

Discussion in 'General Discussion' started by skipjack, Dec 14, 2003.

  1. skipjack

    skipjack Member

    Joined:
    Dec 4, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    Is there a fix for the cppop bug? The one where you have to keep restarting cppop very often as it seems to stop working, at least every day and sometimes several times a day.

    I have looked around and may have missed how to fix it.

    Thanks
    Skipjack.
     
  2. bataylor

    bataylor Member

    Joined:
    Oct 4, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Vancouver, BC, Canada
    I'm having the same problem, I think. cppop seems to randomly go down recently, though along with it goes all of CPanel (which means customers can't connect to CPanel or the pop server...).

    And the service manager doesn't seem to be catching this and restarting it. What's going on?


    Brett
     
  3. skipjack

    skipjack Member

    Joined:
    Dec 4, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Dunno!
    Pain in the ass tho.
    This CPanel ain't cheap either.

    Tony
     
  4. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    If you are running redhat & kernel 2.4.20-28.9 then try the latest edge build. There is a bug in the kernel causing probs w/ cppop and Nick has created what should be a work around... it is edge! Check the changelog.
     
  5. skipjack

    skipjack Member

    Joined:
    Dec 4, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Yeah,

    I thought there might be something in the latest build so I have been running edge... But no luck. I have to keep an eye on it all the time so when it stops I can restart it.
    Not Ideal. I thought of having a cron job restart cppop regularly. Very cude I know but it would mean I didn't have to do it at least once a day some times twice or three times..

    Tony
     
  6. Toe

    Toe Registered

    Joined:
    Nov 25, 2002
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here too. If anybody finds even a usable workaround, let us know. :(
     
  7. skipjack

    skipjack Member

    Joined:
    Dec 4, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    Not a workaround as such but I have a cron job run /scripts/restartsrv cppop at 7:05 every morning. this restarts cppop and the clients can get email when they start work. If I need to increase the number of times I restart it I will edit the cron job. It is a very crude method but it does offer a solution. I am open to all suggestions as to a better way of fixing this, but as no-one from cpanel as any comments. I supose we are on our own here.

    Tony
     
  8. markie

    markie BANNED

    Joined:
    Oct 5, 2003
    Messages:
    143
    Likes Received:
    0
    Trophy Points:
    0
    What bug in what kernel? We are running kernel 2.4.20-27.7
    and our users are having pop issue!!
     
  9. Theo

    Theo Registered

    Joined:
    Aug 3, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Breda NL
    Test + restart script for cppop

    Hi,

    I made this script to restart cppop when it hangs.

    Theo

    Code:
    #!/bin/bash
    # this script is used to check and restart cppop
    # use the cron to run it every 15 minutes or so
    #
    # made by Theo Schipper (theo at trends dot org)
    # use at your own risk
    #
    # enter your own values:
    host="host.tld"
    mailto="youremail@somewhere.tld"
    #
    pid=$$
    #
    pipe()
    {
    sleep 3
    echo -e "quit"
    sleep 6
    }
    info=$(pipe|/usr/bin/telnet $host 110 2>&1)
    echo $info | grep "+OK" > /dev/null 2>&1
    if [ $? -ne 0 ]; then
    #
    # if pop does not work the code below is executed
    #
    echo "Subject: Pop3 does not work on $host" > /tmp/cppop$pid.lis
    echo "" >> /tmp/cppop$pid.lis
    top -b -n1 | head -20 >> /tmp/cppop$pid.lis
    /usr/sbin/sendmail -F "POP3 watcher" $mailto < /tmp/cppop$pid.lis
    # restart cppop
    /scripts/restartsrv cppop
    # cleanup
    rm /tmp/cppop$pid.lis
    fi
    
     
    #9 Theo, Jan 27, 2004
    Last edited: Jan 28, 2004
  10. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    All over!
    We have the same problem but it only happens after we upgrade cPanel every week. I go in & restart ccpop & all is fine till the next week. We are running...

    WHM 8.6.0 cPanel 8.7.0-E25
    RedHat 9 - WHM X v2.1.1
     
  11. wimp

    wimp Well-Known Member

    Joined:
    Jul 13, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    16
    hi,
    i have not that problem (probably because i run cPanel 8.5.4-R72)
    BUT afther upgrade to kernel 2.4.20-28.9 i saw that the sever goes slow and has high CPUsage.. goes from 3-.00 -> 20.00
    befor it was never go over 2.50 Max. 3.00
    Are there any other bug in that kernel version?


    Thanks a lot.

    my system is:
    RedHat 7.3
    Apache 1.3.28
    cPanel 8.5.4-R72
     
Loading...

Share This Page