The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CentOS 4.2 x86_64 and missed perl modules

Discussion in 'General Discussion' started by dundarr, Feb 2, 2006.

  1. dundarr

    dundarr Registered

    Joined:
    Nov 12, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    We just hired a new server CentOS 4.2 x86_64, cPanel 10.8.1-R113. It is using RELEASE cpanel flavour.
    Screen gets blank when trying to configure a DNS cluster ( perl script just dies ) .
    We need to install the Tie::IxHash module, or at least that is what solver other people's problem with a very similar config.
    When we try to update with upcp or updating from WHM, there are some problems with GD lib and this error message: Method: Perl Expect

    In one line, it seems perl is somewhat broken.
    Any advice ?
    Should we try to update to bleeding EDGE cpanel version or better just download and install a new perl tar.gz install file ?

    thanks
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You can expect a lot of problems with x86_64. IMX the 64bit OS is not ready for productions servers and you're much better off redoing the OS install to i686 32bit CentOSv4.

    As to the problem, you need to post more of the errors that you're seeing.

    Also, which version of perl do you have installed?

    perl -v

    The procedure to install the module you mentioned would be :

    /scripts/perlinstaller Tie::IxHash
     
Loading...

Share This Page