The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CentOS 5 - PHP4 + PHP5

Discussion in 'General Discussion' started by M0nKeY, Jun 2, 2008.

  1. M0nKeY

    M0nKeY Member

    Joined:
    Jul 8, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I'm wondering if anyone has successfully used PHP 4 and 5 on CentOS 5 with cPanel.

    I notice that the OS does not have official RPMs for PHP4. Would I run into any problems if I use the 3rd party RPMs?

    http://www.labcoding.com/linux/php4-php4-pear-and-php5-on-centos-5/

    Will I be able to use the account specific PHP4/5 selection in cPanel? (I'm, also interested in the "Concurrent PHP" as I have never used cPanel before. This sounds much better than running one as CGI)

    Any info would be greatly appreciated.

    EDIT: Ok upon futher investigation it appears that cPanel compiles php from source with easyapache? If that is the case then there should be no problem.
     
    #1 M0nKeY, Jun 2, 2008
    Last edited: Jun 2, 2008
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Yes, we compile from source with EasyApache :).

    Most Concurrent PHP setups do allow for account-specific PHP 4/5 selection. However as EOL for PHP 4 is in little more than 2 months, you may wish to encourage your users to use PHP 5 as soon as possible. The way users can change this is by going to the PHP Configuration screen of cPanel and at the top of that screen they will see a drop-down for PHP 4 or PHP 5 to be default.
     
Loading...

Share This Page