CentOS 5 problem installing OpenSSL

vladi2n

Member
Jan 7, 2003
10
0
151
On a new box with centOS5 installing current cPanel 11 got error:

et_SSLeay.pm-1.30/ptrtstrun.pl
Net_SSLeay.pm-1.30/README
Net_SSLeay.pm-1.30/Makefile.PL

CPAN.pm: Going to build F/FL/FLORA/Net_SSLeay.pm-1.30.tar.gz

Checking for OpenSSL-0.9.6j or 0.9.7b or newer...
I could not find your OpenSSL in `OTHERLDFLAGS=-L/usr/lib64'
Please provide OpenSSL-0.9.6j or
OpenSSL-0.9.7b installation directory (get from
http://www.openssl.org/ if you don't have it; please note that
SSLeay is no longer supported, see README) (C-c to abort):


I could not find your OpenSSL in `'
Please provide OpenSSL-0.9.6j or
OpenSSL-0.9.7b installation directory (get from
http://www.openssl.org/ if you don't have it; please note that
SSLeay is no longer supported, see README) (C-c to abort):
inactivity_timeout reached


Before I install cPanel I have run:

yum update
yum remove cups sendmail
yum install gcc gcc-devel
echo "CPANEL=current" >> /etc/cpupdate.conf

Thanks in Advance :)
 

macooper

Member
May 3, 2004
14
0
151
I installed the 32 bit version, but after checking the install (which did complete) I had some package build problems. Running :

yum install redhat-rpm-config

fixed them. Apparently, some of the RPM's are not available, so cpanel install is currently building from source for the missing packages, which requires those tools to work.

HTH