Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED CentOS 7.4 + network.service

Discussion in 'Workarounds and Optimization' started by AshleyIn1080p, Oct 21, 2017.

  1. AshleyIn1080p

    AshleyIn1080p Registered

    Joined:
    Oct 21, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Southampton, United Kingdom
    cPanel Access Level:
    Root Administrator
    Hi all i have installed Cent OS 7.4 on my Dedicated Server, but having issue with network.service with static IP assigned, it's fine if set as DHCP but not Static IP, i was wondering if someone could point me in the right direction, it ping fine under DHCP but not Static IP.

    Thanks

    P.S sorry if this is in the wrong topic.
     
  2. HostingH

    HostingH Well-Known Member

    Joined:
    Jan 13, 2008
    Messages:
    123
    Likes Received:
    17
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    Hello,

    You have to check /etc/sysconfig/network-scripts/ifcfg-eth0 and resolve.conf to set static IP on the server.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. AshleyIn1080p

    AshleyIn1080p Registered

    Joined:
    Oct 21, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Southampton, United Kingdom
    cPanel Access Level:
    Root Administrator
    Okay, in ifcfg-eth0 i have this..

    DEVICE=eth0
    BOOTPROTO=static
    ONBOOT=yes
    NM_CONTROLLED=no
    IPADDR=62.***.***.***
    NETMASK=255.255.255.255
    GATEWAY=62.***.***.***

    and in resolve.conf i have this..

    nameserver 8.8.4.4
    nameserver 8.8.8.8

    Have i missed something?

    Nevermind sorted it now, seems i was missing BROADCAST from config
     
    #3 AshleyIn1080p, Oct 22, 2017
    Last edited: Oct 22, 2017
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,672
    Likes Received:
    1,788
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm glad to see you were able to solve the issue. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice